Bug 1812622 - Failing Integration Test 'downloads new bundle for operator-hub ' on release-openshift-ocp-installer-console-aws-4.3
Summary: Failing Integration Test 'downloads new bundle for operator-hub ' on release-...
Keywords:
Status: CLOSED DUPLICATE of bug 1811886
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: 4.5.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 17:49 UTC by David Taylor
Modified: 2020-04-06 18:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-06 18:21:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Taylor 2020-03-11 17:49:09 UTC
Description of problem:

release-openshift-ocp-installer-console-aws-4.3: FAILING
https://testgrid.k8s.io/redhat-openshift-ocp-release-4.3-informing#release-openshift-ocp-installer-console-aws-4.3&sort-by-flakiness=

Link to job:
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-console-aws-4.3/920

"downloads new bundle for operator-hub
Error: Failed expectation
    at /go/src/github.com/openshift/console/frontend/integration-tests/tests/performance.scenario.ts:79:53"


Version-Release number of selected component (if applicable):
4.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 bpeterse 2020-03-11 18:01:43 UTC
```
Error: Failed expectation
    at /go/src/github.com/openshift/console/frontend/integration-tests/tests/performance.scenario.ts:79:53
    at step (/go/src/github.com/openshift/console/frontend/integration-tests/tests/performance.scenario.ts:33:23)
    at Object.next (/go/src/github.com/openshift/console/frontend/integration-tests/tests/performance.scenario.ts:14:53)
    at fulfilled (/go/src/github.com/openshift/console/frontend/integration-tests/tests/performance.scenario.ts:5:58)
    at process._tickCallback (internal/process/next_tick.js:68:7)
```

Report including screenshot: 

https://storage.googleapis.com/origin-ci-test/logs/release-openshift-ocp-installer-console-aws-4.3/920/artifacts/e2e-aws-console/gui_test_screenshots/test-gui-report.html

Comment 4 Samuel Padgett 2020-04-03 13:09:29 UTC
Note that we've disabled these tests in master because they haven't been reliable.

https://github.com/openshift/console/blob/master/frontend/integration-tests/tests/performance.scenario.ts#L65

Comment 6 Samuel Padgett 2020-04-06 18:21:21 UTC
This looks like a duplicate of bug 1811886. The build problems resulted in different bundle sizes randomly.

*** This bug has been marked as a duplicate of bug 1811886 ***


Note You need to log in before you can comment on or make changes to this bug.