Bug 181292 - pyxf86config cannot rebuild in rawhide
pyxf86config cannot rebuild in rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
https://bugs.freedesktop.org/show_bug...
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-12 17:21 EST by Jesse Keating
Modified: 2013-01-09 21:29 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.0.1-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 15:32:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5882 None None None Never

  None (edit)
Description Jesse Keating 2006-02-12 17:21:28 EST
Pleahttp://porkchop.redhat.com/beehive/logs/pyxf86config-705240-x86_64-ls20-bc2-14.build.redhat.com.log
x86_64-redhat-linux-gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC -Wall
-I../include -I/usr/include/python2.4 -I/usr/include/glib-2.0
-I/usr/lib64/glib-2.0/include -DXFree86Server -DIN_MODULE -DXFree86Module
-DXFree86LOADER -I/usr/include/xorg -o ixf86configmodule.so -shared
-Wl,--export-dynamic pyxf86conf.o xf86config_ext.o  -lgmodule-2.0 -ldl
-lgobject-2.0 -lglib-2.0 -L/usr/lib64 -lxf86config
/usr/bin/ld: /usr/lib64/libxf86config.a(Files.o): relocation R_X86_64_32 against
`a local symbol' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/libxf86config.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[1]: *** [ixf86configmodule.so] Error 1
make[1]: Leaving directory `/usr/src/build/705786-x86_64/BUILD/pyxf86config-0.3.23'
make: *** [all] Error 2
Comment 1 Ray Strode [halfline] 2006-02-12 17:50:18 EST
Looks like xorg-x11-server-sdk needs to use -fPIC on x86-64.
Comment 2 Mike A. Harris 2006-02-13 17:04:34 EST
Indeed.  All .a libs should be -fPIC if there are no shared versions, which
is what happened in previous releases.  In 7.0, all the normal X libs are
shared now, so we don't even ship static ones.  libxf86config is a special
case, as it's part of the X server build rather than coupled with the other
libs.  Looks like this one just got left out in the rain during the mono->modu
transition.

Will be fixed in a future build.

Also filed upstream for inclusion in the next xserver/xorg release:

    https://bugs.freedesktop.org/show_bug.cgi?id=5882
Comment 3 Jeremy Katz 2006-03-06 15:32:29 EST
Bad hack that's okay enough for our packages committed in -8.  Leaving the
upstream bug open so it can be fixed correctly there

Note You need to log in before you can comment on or make changes to this bug.