Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
The FDP team is no longer accepting new bugs in Bugzilla. Please report your issues under FDP project in Jira. Thanks.

Bug 1812958

Summary: [OSP 13-15-16] dump_create: failed to get ifindex for tap* : Operation not supported
Product: Red Hat Enterprise Linux Fast Datapath Reporter: Timothy Redaelli <tredaelli>
Component: openvswitch2.11Assignee: Open vSwitch development team <ovs-team>
Status: CLOSED ERRATA QA Contact: Zhiqiang Fang <zfang>
Severity: urgent Docs Contact:
Priority: urgent    
Version: FDP 20.ACC: aconole, agurenko, ahrechan, akaris, amasolov, apevec, atragler, bcafarel, bfournie, bjacot, cfontain, chrisbro, chrisw, coldford, ctrautma, dhill, dvd, ekuris, fhallal, fiezzi, igortiunov, jhsiao, jlibosva, kfida, michele, mvalsecc, ovs-qe, ralongi, rhos-maint, rszmigie, tredaelli, zfang
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: openvswitch2.11-2.11.0-49.el8fdp Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1812613 Environment:
Last Closed: 2020-04-14 14:17:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Comment 3 Zhiqiang Fang 2020-03-25 19:26:48 UTC
Reproduced:

[root@netqe4 ~]# systemctl start openvswitch
[root@netqe4 ~]# ovs-vsctl add-br mybr
[root@netqe4 ~]# ovs-vsctl add-port mybr myport -- set Interface myport type=internal
[root@netqe4 ~]# ip net add myns
[root@netqe4 ~]# ip l s dev myport netns myns
[root@netqe4 ~]# grep myport /var/log/openvswitch/ovs-vswitchd.log
2020-03-25T18:38:05.344Z|00032|bridge|INFO|bridge mybr: added interface myport on port 1
2020-03-25T18:38:25.137Z|00001|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:25.142Z|00002|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:25.642Z|00003|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
...
2020-03-25T18:38:36.156Z|00024|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:37.157Z|00026|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:38.158Z|00028|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
[root@netqe4 ~]# 
[root@netqe4 ~]# 
[root@netqe4 ~]# 
[root@netqe4 ~]# tail -f /var/log/openvswitch/ovs-vswitchd.log
2020-03-25T18:38:53.171Z|00057|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:53.172Z|00058|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:54.172Z|00059|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:54.172Z|00060|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:55.173Z|00061|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:55.173Z|00062|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:56.175Z|00063|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:56.175Z|00064|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:57.175Z|00065|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:57.175Z|00066|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:58.176Z|00067|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:58.176Z|00068|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:38:59.177Z|00069|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:38:59.177Z|00070|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:00.178Z|00071|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:00.178Z|00072|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:01.179Z|00073|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:01.179Z|00074|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:02.180Z|00075|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:02.180Z|00076|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:03.182Z|00077|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:03.182Z|00078|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:04.183Z|00079|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:04.183Z|00080|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:05.184Z|00081|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:05.184Z|00082|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:06.186Z|00083|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:06.186Z|00084|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:07.187Z|00085|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:07.187Z|00086|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:08.189Z|00087|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:08.189Z|00088|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
2020-03-25T18:39:09.190Z|00089|netdev_tc_offloads(revalidator57)|ERR|Dropped 1 log messages in last 0 seconds (most recently, 0 seconds ago) due to excessive rate
2020-03-25T18:39:09.190Z|00090|netdev_tc_offloads(revalidator57)|ERR|dump_create: failed to get ifindex for myport: Operation not supported
^C
[root@netqe4 ~]# uname -r
4.18.0-147.el8.x86_64
[root@netqe4 ~]# rpm -q openvswitch2.11
openvswitch2.11-2.11.0-45.el7fdn.x86_64
[root@netqe4 ~]# 
[root@netqe4 ~]# 



Verified:

[root@netqe4 ~]# systemctl start openvswitch
[root@netqe4 ~]# ovs-vsctl add-br mybr
[root@netqe4 ~]# ovs-vsctl add-port mybr myport -- set Interface myport type=internal
[root@netqe4 ~]# ip net add myns
[root@netqe4 ~]# ip l s dev myport netns myns
[root@netqe4 ~]# grep myport /var/log/openvswitch/ovs-vswitchd.log
2020-03-25T19:24:07.202Z|00032|bridge|INFO|bridge mybr: added interface myport on port 1
[root@netqe4 ~]# 
[root@netqe4 ~]# 
[root@netqe4 ~]# tail -f /var/log/openvswitch/ovs-vswitchd.log
2020-03-25T19:24:00.735Z|00023|ofproto_dpif|INFO|system@ovs-system: Datapath supports ct_label
2020-03-25T19:24:00.735Z|00024|ofproto_dpif|INFO|system@ovs-system: Datapath supports ct_state_nat
2020-03-25T19:24:00.735Z|00025|ofproto_dpif|INFO|system@ovs-system: Datapath supports ct_orig_tuple
2020-03-25T19:24:00.735Z|00026|ofproto_dpif|INFO|system@ovs-system: Datapath supports ct_orig_tuple6
2020-03-25T19:24:00.787Z|00027|bridge|INFO|bridge mybr: added interface mybr on port 65534
2020-03-25T19:24:00.788Z|00028|bridge|INFO|bridge mybr: using datapath ID 00005ea22428e94b
2020-03-25T19:24:00.788Z|00029|connmgr|INFO|mybr: added service controller "punix:/var/run/openvswitch/mybr.mgmt"
2020-03-25T19:24:04.814Z|00030|memory|INFO|123528 kB peak resident set size after 10.3 seconds
2020-03-25T19:24:04.814Z|00031|memory|INFO|handlers:23 ports:1 revalidators:9 rules:5
2020-03-25T19:24:07.202Z|00032|bridge|INFO|bridge mybr: added interface myport on port 1
^C
[root@netqe4 ~]# uname -r
4.18.0-147.el8.x86_64
[root@netqe4 ~]# rpm -q openvswitch2.11
openvswitch2.11-2.11.0-49.el7fdn.x86_64

Comment 5 errata-xmlrpc 2020-04-14 14:17:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1459