Bug 1813004 - remove etcd DNS entries in installer because etcd no longer uses DNS
Summary: remove etcd DNS entries in installer because etcd no longer uses DNS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1813003
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-12 17:16 UTC by Suresh Kolichala
Modified: 2020-05-04 11:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1813003
Environment:
Last Closed: 2020-05-04 11:45:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3282 0 None closed [release 4.4] Bug 1813004: etcd: remove etcd DNS entries because etcd no longer uses DNS 2020-09-20 15:09:55 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:46:15 UTC

Description Suresh Kolichala 2020-03-12 17:16:25 UTC
+++ This bug was initially created as a clone of Bug #1813003 +++

Description of problem:
Installer doesn't need to generate DNS entries for etcd, as etcd no longer uses DNS.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install 4.4
2.
3.

Actual results:
The installed cluster DNS has entries for etcd members.

Expected results:
No DNS is needed because etcd no longer uses DNS.

Additional info:

Comment 3 ge liu 2020-03-20 04:03:13 UTC
Verified with 4.4.0-0.nightly-2020-03-19-205629, checked installer log, there is not etcd dns entry.

Comment 5 errata-xmlrpc 2020-05-04 11:45:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.