Bug 1813031 - [4.4.z] Whereabouts IPAM CNI should use CR in whereabouts.cni.cncf.io
Summary: [4.4.z] Whereabouts IPAM CNI should use CR in whereabouts.cni.cncf.io
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Douglas Smith
QA Contact: Weibin Liang
URL:
Whiteboard: SDN-CI-IMPACT,SDN-BP,SDN-STALE
Depends On: 1812245
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-12 18:46 UTC by Douglas Smith
Modified: 2020-05-26 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1812245
Environment:
Last Closed: 2020-05-26 16:50:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift whereabouts-cni pull 8 None closed Bug 1813031: Updates CRD name to whereabouts.cni.cncf.io [backport 4.4] 2020-06-18 13:30:51 UTC
Red Hat Product Errata RHBA-2020:2180 None None None 2020-05-26 16:50:53 UTC

Description Douglas Smith 2020-03-12 18:46:35 UTC
+++ This bug was initially created as a clone of Bug #1812245 +++

Description of problem:
Whereabouts IPAM CNI should use CR in whereabouts.cni.cncf.io

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-03-10-155709

How reproducible:
Always

Steps to Reproduce:
1. curl -s https://raw.githubusercontent.com/weliang1/Openshift_Networking/master/Features/multus/whereabouts-macvlan.yaml   | oc create -f-
2. curl -s https://raw.githubusercontent.com/weliang1/Openshift_Networking/master/Features/multus/pod.yaml | sed s/pod-name/pod-macvlan-bridge-whereabouts/g | sed s/net-attach-def/macvlan-bridge-whereabouts/g | oc create -f- 

Actual results:
 Warning  FailedCreatePodSandBox  11s        kubelet, ip-10-0-145-60.us-east-2.compute.internal  Failed to create pod sandbox: rpc error: code = Unknown desc = failed to create pod network sandbox k8s_pod-macvlan-bridge-whereabouts_test_651a9a80-5349-4c9a-91cf-31eeb73f5b53_0(e4a9b1c372188fbb47187a3636043942098c962924f0d6f1fce9f614978e9533): Multus: [test/pod-macvlan-bridge-whereabouts]: error adding container to network "whereabouts": delegateAdd: error invoking DelegateAdd - "macvlan": error in getting result from AddNetwork: Error assigning IP: no matches for kind "IPPool" in version "whereabouts.cni.k8s.io/v1alpha1"

Expected results:
Pod should get correct IP address for second interface

Additional info:

--- Additional comment from Weibin Liang on 2020-03-11 15:08:37 UTC ---

Same issue happened in 4.4.0-0.nightly-2020-03-11-095741

--- Additional comment from Douglas Smith on 2020-03-11 20:20:30 UTC ---

I found an additional bug while fixing this one, BZ @ https://bugzilla.redhat.com/show_bug.cgi?id=1812676

Comment 2 Douglas Smith 2020-05-07 15:26:52 UTC
PR @ https://github.com/openshift/whereabouts-cni/pull/8

Comment 5 Weibin Liang 2020-05-18 14:42:15 UTC
Tested and verified in 4.4.0-0.nightly-2020-05-18-115348

Comment 7 errata-xmlrpc 2020-05-26 16:50:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.