Bug 1813052 - Notification drawer shows up behind the side panel of the Workloads/Topology side panel, thus unavailable
Summary: Notification drawer shows up behind the side panel of the Workloads/Topology ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1814927
TreeView+ depends on / blocked
 
Reported: 2020-03-12 20:06 UTC by Serena
Modified: 2020-08-04 18:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: z index order issue Consequence: causes notification drawer to appear behind workload / topology side panel Fix: update the z index to fix the issue Result: notification drawer is no longer hidden
Clone Of:
: 1814927 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:05:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
alert displays on top layer (196.70 KB, image/png)
2020-03-20 03:25 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4725 None closed Bug 1813052: Fix workload detail child overlapping notification drawer 2020-06-23 09:22:59 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:05:20 UTC

Description Serena 2020-03-12 20:06:37 UTC
Description of problem:


Go to a Project in the Admin Perspective, click on Workloads tab, and select something so the side panel is displayed.  Now open the Notification drawer.
It opens behind the side panel, so the content of the notification drawer is unavailable.

Version-Release number of selected component (if applicable):
I'm on a daily 4.4 cluster

How reproducible:
Consistent - above.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 XiaochuanWang 2020-03-20 03:25:11 UTC
Created attachment 1671687 [details]
alert displays on top layer

Comment 4 XiaochuanWang 2020-03-20 03:27:28 UTC
Now the notification alert display on top layer of page side panel.
Please refer to the screenshot.
Verified on 4.5.0-0.nightly-2020-03-19-112259.

Comment 6 errata-xmlrpc 2020-08-04 18:05:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.