Bug 181307 - pirut doesn't work with a proxy (even if yum does)
pirut doesn't work with a proxy (even if yum does)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 07:18 EST by oll
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: test3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 15:15:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oll 2006-02-13 07:18:55 EST
Description of problem:

Pirut simply doesn't work behind a proxy

Version-Release number of selected component (if applicable):
pirut-0.9.10-1

How reproducible:
Always

Steps to Reproduce:
1.run pirut
2.
3.
  
Actual results:
"Retrieving Software information window appears" but freezes untill I kill it.

Expected results:
I don't know : I never saw the next point :-)

Additional info:
Setting  the http_proxy variable makes yum work very well.
I also set gnome proxy preferences.

I think it's a proxy problem since strace gives me :
connect(.....sin addr=inet addr("209.132.177.50"}} and direct connection are
indeed firewalled
Comment 1 Rahul Sundaram 2006-02-20 05:46:30 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 oll 2006-02-20 06:00:45 EST
Thank you very much : this is indeed now fixed.
But I have exactly the same problem with system-config-kickstart ?
Will it be also solved soon or should I open a bug ?
Comment 3 Rahul Sundaram 2006-02-20 11:38:21 EST
Better to file another report on it. Thanks

Note You need to log in before you can comment on or make changes to this bug.