Bug 1813099 - Condition for RHEL 7.6 in NETWORK_LACP_BOND_LACPDU_ISSUE rule incorrect
Summary: Condition for RHEL 7.6 in NETWORK_LACP_BOND_LACPDU_ISSUE rule incorrect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hybrid Cloud Console (console.redhat.com)
Classification: Red Hat
Component: Insights - Rules
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Chen Li Zhong
QA Contact: Jaylin Zhou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-12 23:41 UTC by Bryan Kinney
Modified: 2020-05-14 00:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-01 08:07:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bryan Kinney 2020-03-12 23:41:02 UTC
Description of problem:
Condition for NETWORK_LACP_BOND_LACPDU_ISSUE rule is triggered by a kernel version that is also fixed. The condition uses a later kernel version (kernel-3.10.0-1062.el7). But the fix is also available in kernel-3.10.0-957.35.1.el7.

[ bonding/802.3ad: fix slave link initialization transition states ]
( https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=334031219a84b9994594015aab85ed7754c80176 )

Referencing rule proposal: https://projects.engineering.redhat.com/browse/CEECBA-2600

KB mentions correct kernel version in Resolution table for RHEL 7.6-EUS.
But condition doesn't include this kernel version.
https://access.redhat.com/solutions/4122011

Customer can not use the kernel-3.10.0-1062.el7 version because the live kernel patching enhancement is not applicable to the Customer's patching processes.

Version-Release number of selected component (if applicable):
RHEL 7.6
kernel-3.10.0-957.35.1.el7

How reproducible:
Only update to kernel-3.10.0-957.35.1.el7 and not the later kernel-3.10.0-1062.el7

Steps to Reproduce:
1. Don't apply the live kernel patching enhancement (RHEA-2019:2011 and onward)
2. Only update to kernel-3.10.0-957.35.1.el7

Actual results:
Fixed kernel-3.10.0-957.35.1.el7 is triggering the rule.

Expected results:
Fixed kernel version shouldn't trigger rule.

Additional info:
RHEL 7.6 EUS still has about 3 more years of support.

Comment 1 Chen Li Zhong 2020-03-20 08:33:24 UTC
Fixed. Please let customer to check in cloud.redhat.com

Comment 2 Chen Li Zhong 2020-04-01 08:07:58 UTC
Confirmed by customer in case https://access.redhat.com/support/cases/#/case/02601722


Note You need to log in before you can comment on or make changes to this bug.