Bug 181316 - anaconda does not handle dmraid (promise pdc20376) stripe single drives correctly
Summary: anaconda does not handle dmraid (promise pdc20376) stripe single drives corre...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-13 14:13 UTC by Andreas Bierfert
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-13 23:28:44 UTC
Type: ---


Attachments (Terms of Use)

Description Andreas Bierfert 2006-02-13 14:13:43 UTC
While trying to install 20060210 rawhide tree I came across this bug:
I pulled out a hd from my old i386 (Asus A7V8X) with Promise PDC20376 which has
2 SATA and 1 PATA port. The driv ewas added to a one disc stripe raid in order
for windows to see it. This worked w/o any problems there. I put the drive in as
hdb on my new workstation and anaconda detected it as mapper/pdc.... something.
When I tried to setup the disc layout anaconda actually managed to add the new
partition  but the format afterwards failed. The only fix was to dmraid -rE the
metadata and install as it should have been to hdb...

Comment 1 Peter Jones 2006-02-13 23:28:44 UTC
This isn't really fixable -- if we find valid raid metadata, we have no way to
tell if BIOS is set up to boot it or not.  So you can either remove it (with
"dmraid" or via the bios itself), or you can boot the installer with "nodmraid",
which will make it ignore the metadata.


Note You need to log in before you can comment on or make changes to this bug.