Bug 1813174 - Fail to delete slaved dummy soon after nmstate rollback
Summary: Fail to delete slaved dummy soon after nmstate rollback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: nmstate
Version: 8.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.3
Assignee: Gris Ge
QA Contact: Mingyu Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 07:14 UTC by Mingyu Shi
Modified: 2020-11-04 03:10 UTC (History)
5 users (show)

Fixed In Version: nmstate-0.3.2-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 03:08:25 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
reproducer and log.txt (8.55 KB, text/plain)
2020-03-13 07:14 UTC, Mingyu Shi
no flags Details
verified.log (12.74 KB, text/plain)
2020-06-23 08:50 UTC, Mingyu Shi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github nmstate nmstate issues 947 0 None open Virtual slave interface is not deleted when master marked as absent 2020-08-27 15:29:56 UTC
Red Hat Product Errata RHBA-2020:4696 0 None None None 2020-11-04 03:08:42 UTC

Description Mingyu Shi 2020-03-13 07:14:25 UTC
Created attachment 1669860 [details]
reproducer and log.txt

Description of problem:
Fail to delete slaved dummy soon after nmstate rollback

Version-Release number of selected component (if applicable):
nmstate-0.2.6-3.8.el8.noarch
NetworkManager-1.22.8-4.el8.x86_64
DISTRO=RHEL-8.2.0-20200310.0
Linux hp-dl380pg8-07.rhts.eng.pek2.redhat.com 4.18.0-187.el8.x86_64 #1 SMP Sat Mar 7 03:42:33 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
6 out of 10

Steps to Reproduce:
1. See the attachment for reproducer and logs
2.
3.

Actual results:
dummy preserved and marked down

Expected results:
Delete dummy

Additional info:

Comment 4 Mingyu Shi 2020-06-23 08:50:43 UTC
Created attachment 1698408 [details]
verified.log

Version:
nmstate-0.3.2-1.el8.noarch
NetworkManager-1.26.0-0.1.el8.x86_64
DISTRO=RHEL-8.3.0-20200616.0
Linux hp-dl388g8-08.rhts.eng.pek2.redhat.com 4.18.0-214.el8.x86_64 #1 SMP Fri Jun 12 08:55:08 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

This is covered in case: kernel/networking/nmstate/bugs/verification-is-failing-on-bond-miimon-options_bz1806524

Run for 10 times, no failure.

Comment 7 errata-xmlrpc 2020-11-04 03:08:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (nmstate bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4696


Note You need to log in before you can comment on or make changes to this bug.