Bug 1813195 - File '/opt/rh/rh-perl530/root/usr/lib64/perl5/vendor_perl/DBD/mysql.pm' has wrong interpreter '#!/usr/bin/perl'
Summary: File '/opt/rh/rh-perl530/root/usr/lib64/perl5/vendor_perl/DBD/mysql.pm' has w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: perl-DBD-MySQL
Version: rh-perl530
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
: 3.5
Assignee: perl-maint-list
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 08:35 UTC by Martin Kyral
Modified: 2020-05-26 09:25 UTC (History)
1 user (show)

Fixed In Version: rh-perl530-perl-DBD-MySQL-4.050-6.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 09:25:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:2259 0 None None None 2020-05-26 09:25:28 UTC

Description Martin Kyral 2020-03-13 08:35:13 UTC
Description of problem:
The general-shebang-check test discovered, that the /opt/rh/rh-perl530/root/usr/lib64/perl5/vendor_perl/DBD/mysql.pm file has wrong shebang.
Generally, all the scripts shipped in a collection shall have shebangs pointing to the collection or using env.


Version-Release number of selected component (if applicable):
rh-perl530-perl-DBD-MySQL-4.050-5.el7


How reproducible:


Steps to Reproduce:
1. head -n1 /opt/rh/rh-perl530/root/usr/lib64/perl5/vendor_perl/DBD/mysql.pm 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Pisar 2020-03-13 09:49:52 UTC
Thank you for the report. The file actually should not contain any shebang.

Comment 8 errata-xmlrpc 2020-05-26 09:25:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2259


Note You need to log in before you can comment on or make changes to this bug.