Bug 18132 - Shutdown on Gateway Solo 9300 hangs without poweroff
Shutdown on Gateway Solo 9300 hangs without poweroff
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 16:14 EDT by bcling
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 03:29:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bcling 2000-10-02 16:14:44 EDT
Doing a shutdown -h or init 0 doesn't fully shut off a Gateway 9300
laptop.  Haven't recompiled the kernel yet to see if it resolves this
issue.  6.2 stock kernel worked fine.
Comment 1 tannhaus 2000-10-03 03:29:14 EDT
I've had a similar problem with an Epox MVP3G5 motherboard.  When I was running
redhat 6.2 I had kernel 2.2.17 compiled from sources.  When I shutdown, the
system powered off.  I upgraded to redhat 7.0 copied this exact same kernel into
boot, ran lilo on it, etc.  But, in Redhat 7.0, when it says system halted, it
just sits there.  It never powers down.  This is the EXACT SAME kernel that
shutdown perfectly in RedHat 6.2.
Comment 2 Nalin Dahyabhai 2000-10-05 14:30:44 EDT
The "halt" command (and the equivalent, "shutdown -h"), only halts the kernel in
newer versions of init (this did not work correctly before due to the complexity
of the halt command signalling init to switch runlevels, and init then having to
figure out which flags halt was run with).  If you wish to have the machine
power itself off, the command to use is "poweroff".

Note You need to log in before you can comment on or make changes to this bug.