Bug 1813201 - Scripts in rh-perl530-perl-Locale-Codes-tests have wrong shebangs
Summary: Scripts in rh-perl530-perl-Locale-Codes-tests have wrong shebangs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: perl-Locale-Codes
Version: rh-perl530
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
: 3.5
Assignee: perl-maint-list
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 08:46 UTC by Martin Kyral
Modified: 2020-05-26 09:25 UTC (History)
1 user (show)

Fixed In Version: rh-perl530-perl-Locale-Codes-3.62-3.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 09:25:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:2259 0 None None None 2020-05-26 09:25:28 UTC

Description Martin Kyral 2020-03-13 08:46:47 UTC
Description of problem:
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/codes.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/country_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/country_old.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/country_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/currency_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/currency_old.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/currency_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/do_tests.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/test' has wrong interpreter '#!/usr/bin/sh' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/langext_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/langext_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/langfam_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/langfam_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/language_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/language_old.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/language_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/langvar_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/langvar_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/script_func.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/script_old.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/script_oo.t' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_country.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_currency.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_langext.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_langfam.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_language.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_langvar.pl' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:36 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/libexec/rh-perl530-perl-Locale-Codes/t/vals_script.pl' has wrong interpreter '#!/usr/bin/perl' 

Generally, all the scripts shipped in a collection shall have shebangs pointing to the collection or using env.


Version-Release number of selected component (if applicable):
rh-perl530-perl-Locale-Codes-3.62-2.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Pisar 2020-03-13 10:22:19 UTC
Indeed. I will correct the shebangs since the files have an executable bit set.

Comment 8 errata-xmlrpc 2020-05-26 09:25:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2259


Note You need to log in before you can comment on or make changes to this bug.