Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1813237 - list of installed modules is not remembered across reboots
Summary: list of installed modules is not remembered across reboots
Keywords:
Status: CLOSED DUPLICATE of bug 1804564
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 31
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-13 11:02 UTC by Kamil Páral
Modified: 2020-03-15 13:42 UTC (History)
20 users (show)

Fixed In Version: PackageKit-1.1.12-14.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-13 18:12:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2020-03-13 11:02:27 UTC
Description of problem:
After upgrading to https://bodhi.fedoraproject.org/updates/FEDORA-2020-659dc97781 , it seems that the database of installed/enabled modules is wiped on reboot.

See this:

$ sudo dnf module install ffsend
Last metadata expiration check: 2:04:14 ago on Fri 13 Mar 2020 09:53:19 AM CET.
Dependencies resolved.
================================================================================
 Package  Arch     Version                               Repository        Size
================================================================================
Installing group/module packages:
 ffsend   x86_64   0.2.49-1.module_f31+5376+bde064f8     fedora-modular   2.2 M
Installing weak dependencies:
 xsel     x86_64   1.2.0-25.fc31                         fedora            28 k
Installing module profiles:
 ffsend/default
                                                                               
Enabling module streams:
 ffsend            latest                                                      

Transaction Summary
================================================================================
Install  2 Packages

Total download size: 2.2 M
Installed size: 6.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): xsel-1.2.0-25.fc31.x86_64.rpm            1.1 MB/s |  28 kB     00:00    
(2/2): ffsend-0.2.49-1.module_f31+5376+bde064f8 8.0 MB/s | 2.2 MB     00:00    
--------------------------------------------------------------------------------
Total                                           2.1 MB/s | 2.2 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : xsel-1.2.0-25.fc31.x86_64                              1/2 
  Installing       : ffsend-0.2.49-1.module_f31+5376+bde064f8.x86_64        2/2 
  Running scriptlet: ffsend-0.2.49-1.module_f31+5376+bde064f8.x86_64        2/2 
  Verifying        : ffsend-0.2.49-1.module_f31+5376+bde064f8.x86_64        1/2 
  Verifying        : xsel-1.2.0-25.fc31.x86_64                              2/2 

Installed:
  ffsend-0.2.49-1.module_f31+5376+bde064f8.x86_64   xsel-1.2.0-25.fc31.x86_64  

Complete!

$ sudo dnf module list --installed
Last metadata expiration check: 2:04:25 ago on Fri 13 Mar 2020 09:53:19 AM CET.
Fedora Modular 31 - x86_64
Name   Stream        Profiles   Summary                                         
ffsend latest [d][e] default [d Easily and securely share files from the command
                     ] [i]       line

Fedora Modular 31 - x86_64 - Updates
Name   Stream        Profiles   Summary                                         
ffsend latest [d][e] default [d Easily and securely share files from the command
                     ] [i]       line

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

$ sudo dnf module list --enabled
Last metadata expiration check: 2:04:30 ago on Fri 13 Mar 2020 09:53:19 AM CET.
Fedora Modular 31 - x86_64
Name   Stream        Profiles   Summary                                         
ffsend latest [d][e] default [d Easily and securely share files from the command
                     ] [i]       line

Fedora Modular 31 - x86_64 - Updates
Name   Stream        Profiles   Summary                                         
ffsend latest [d][e] default [d Easily and securely share files from the command
                     ] [i]       line

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

# reboot

$ sudo dnf module list --installed
Last metadata expiration check: 2:05:47 ago on Fri 13 Mar 2020 09:53:19 AM CET.

$ sudo dnf module list --enabled
Last metadata expiration check: 2:05:52 ago on Fri 13 Mar 2020 09:53:19 AM CET.


When I try this without having installed that Bodhi update, everything works as expected, the same module installed/enabled list is printed even after reboot.

Version-Release number of selected component (if applicable):
broken:
dnf-4.2.18-1.fc31.noarch
dnf-data-4.2.18-1.fc31.noarch
dnf-plugins-core-4.0.13-1.fc31.noarch
libdnf-0.43.1-5.fc31.x86_64
PackageKit-1.1.12-13.fc31.x86_64
python3-dnf-4.2.18-1.fc31.noarch
python3-dnf-plugins-core-4.0.13-1.fc31.noarch
python3-libdnf-0.43.1-5.fc31.x86_64
rpm-4.15.1-1.fc31.x86_64

working:
dnf-4.2.18-1.fc31.noarch
dnf-data-4.2.18-1.fc31.noarch
dnf-plugins-core-4.0.13-1.fc31.noarch
libdnf-0.43.1-3.fc31.x86_64
PackageKit-1.1.12-11.fc31.x86_64
python3-dnf-4.2.18-1.fc31.noarch
python3-dnf-plugins-core-4.0.13-1.fc31.noarch
python3-libdnf-0.43.1-3.fc31.x86_64
rpm-4.15.1-1.fc31.x86_64

So the offenders are:
libdnf-0.43.1-5.fc31.x86_64
PackageKit-1.1.12-13.fc31.x86_64

How reproducible:
always

Steps to Reproduce:
1. have a fully updated F31, no modules installed/enabled
2. install https://bodhi.fedoraproject.org/updates/FEDORA-2020-659dc97781
3. sudo dnf module install ffsend
4. verify with "sudo dnf module list --installed" and "sudo dnf module list --enabled"
5. reboot
6. try "sudo dnf module list --installed" and "sudo dnf module list --enabled", see empty lists

Comment 1 Kamil Páral 2020-03-13 11:05:07 UTC
This might be a problem? Since the updated packages are a prerequisite to fix bug 1804564, proposing as an F32 Beta blocker.

Comment 2 Kamil Páral 2020-03-13 11:27:34 UTC
Masking (disabling is not enough) packagekit.service fixes the problem. So this is somehow related to the PK service. However just restarting the service doesn't cause the bug, you have to reboot (or possibly restart something else as well).

Comment 3 Kamil Páral 2020-03-13 11:43:50 UTC
Also, all modules seem to be reset when I click Download in gnome-software and the download completes. So this is all even before I click Install and reboot into the offline upgrade environment.

Comment 4 Miro Hrončok 2020-03-13 12:04:40 UTC
+1 beta blcoker

Comment 5 Kamil Páral 2020-03-13 12:36:25 UTC
If I selectively upgrade just PK or just libdnf, the problem doesn't occur. It only occurs when both are updated to the latest testing version, and PK service is active.

Comment 6 František Zatloukal 2020-03-13 12:51:09 UTC
-1 F32 Beta Blocker

This should be handled in https://bugzilla.redhat.com/show_bug.cgi?id=1804564 , the broken code isn't in F32 dist-git, neither in F31 stable updates. There is no need to have another blocker, just not accepting the broken fix for #1804564 is enough.

Comment 7 Miro Hrončok 2020-03-13 13:11:03 UTC
handling in bz1804564 works for me.

How come the code is not in dist git?

Comment 8 František Zatloukal 2020-03-13 15:13:10 UTC
I've meant it's just just in F31 and F30 dist-git (to emphasize it can be just Previous Release Blocker, thinking about it now, it's not too important/different...).

Comment 9 Adam Williamson 2020-03-13 18:12:23 UTC
We agreed to just treat this as part of 1804564.

*** This bug has been marked as a duplicate of bug 1804564 ***

Comment 10 Fedora Update System 2020-03-14 01:02:08 UTC
PackageKit-1.1.12-14.fc31, libdnf-0.43.1-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-659dc97781

Comment 11 Fedora Update System 2020-03-15 13:42:51 UTC
PackageKit-1.1.12-14.fc31, libdnf-0.43.1-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.