Bug 181328 - Anaconda: Upgrading RHEL4 installation fails due to missing header list
Anaconda: Upgrading RHEL4 installation fails due to missing header list
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McLean
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 09:45 EST by Prarit Bhargava
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 11:14:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-02-13 09:45:28 EST
Description of problem:

When attempting to upgrade from a RHEL4 U3 install from last week to this week,
an error is displayed on the screen.  There is no "back" button and it appears
that the installation is "stuck" at this screen.

Version-Release number of selected component (if applicable):

RHEL4-U3-re0213.nightly

How reproducible: 100%


Steps to Reproduce:
1. Boot using boot.img's vmlinuz and install.img
2. Select upgrade existing RHEL4
  
Actual results:

The following is displayed on the screen:

                  +----------------+ Error +-----------------+                  
                  |                                          |                  
                  | Unable to read header list.  This may    |                  
                  | be due to a missing file or bad media.   |                  
                  | Press <return> to try again.             |                  
                  |                                          |                  
                  |                 +----+                   |                  
                  |                 | OK |                   |                  
                  |                 +----+                   |                  
                  |                                          |                  
                  |                                          |                  
                  +------------------------------------------+                  
Expected results:

Should properly upgrade...

Additional info: I've never tried to upgrade via the internal NFS server.  
Is this a supported option?
Comment 1 Jeremy Katz 2006-02-13 13:20:30 EST
The tree is broken as there isn't an hdlist there 

Also, note that upgrades are only supported in anaconda for going from one major
release to another (ie, RHEL3 -> RHEL4) not any of the little middle steps.

Note You need to log in before you can comment on or make changes to this bug.