Bug 1813355 - File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/*.pl' has wrong interpreter '#!/usr/bin/perl -w'
Summary: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/exam...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: perltidy
Version: rh-perl530
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 3.5
Assignee: perl-maint-list
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 15:08 UTC by Martin Kyral
Modified: 2020-05-26 09:25 UTC (History)
3 users (show)

Fixed In Version: rh-perl530-perltidy-20191203-3.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 09:25:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:2259 0 None None None 2020-05-26 09:25:25 UTC

Description Martin Kyral 2020-03-13 15:08:28 UTC
Description of problem:
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/bbtidy.pl' has wrong interpreter '#!/usr/bin/perl -wn' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/break_long_quotes.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/delete_ending_blank_lines.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/ex_mp.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/filter_example.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/find_naughty.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/perlcomment.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/perllinetype.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/perlmask.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/perltidy_okw.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/perltidyrc_dump.pl' has wrong interpreter '#!/usr/bin/perl -w' 
:: [ 10:24:49 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perltidy-20191203/examples/perlxmltok.pl' has wrong interpreter '#!/usr/bin/perl -w' 

Generally, all the scripts shipped in a collection shall have shebangs pointing to the collection or us

Version-Release number of selected component (if applicable):
rh-perl530-perltidy-20191203-2.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Pisar 2020-03-17 13:30:05 UTC
I confirm this issue and I will correct the shebangs.

Comment 9 errata-xmlrpc 2020-05-26 09:25:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2259


Note You need to log in before you can comment on or make changes to this bug.