Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1813367 - add cluster-etcd operator events for membership changes
Summary: add cluster-etcd operator events for membership changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1813364
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 15:31 UTC by Suresh Kolichala
Modified: 2020-05-04 11:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1813364
Environment:
Last Closed: 2020-05-04 11:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 259 0 None closed [release-4.4] Bug 1813367: add events for membership changes 2020-04-03 02:29:09 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:46:48 UTC

Description Suresh Kolichala 2020-03-13 15:31:25 UTC
+++ This bug was initially created as a clone of Bug #1813364 +++

Description of problem:
Adding more events to the log will help figure out problems with membership (unstarted members).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install a new cluster (or upgrade from previous version)
2. 
3.

Actual results:
The cluster-etcd-operator log doesn't show issues with membership. For example on IPv6 we were still using DNS name, but the logs didn't show. 

Expected results:
If the logs showed the events about adding member as below, we would have known the problem immediately:
#### attempt 0
      member={name="etcd-bootstrap", peerURLs=[https://[fd2e:6f44:5dd8:c956::18]:2380}, clientURLs=[https://[fd2e:6f44:5dd8:c956::18]:2379]
      member={name="", peerURLs=[https://etcd-0.ostest.test.metalkube.org:2380}, clientURLs=[]
      target={name="", peerURLs=[https://etcd-0.ostest.test.metalkube.org:2380}, clientURLs=[], err=<nil>
Adding the unstarted member to the end master-0.ostest.test.metalkube.org

Additional info:

Comment 5 errata-xmlrpc 2020-05-04 11:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.