Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1813374 - cache the etcd client based on the endpoints to avoid reconstruction
Summary: cache the etcd client based on the endpoints to avoid reconstruction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1813373
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-13 15:44 UTC by Suresh Kolichala
Modified: 2020-05-04 11:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1813373
Environment:
Last Closed: 2020-05-04 11:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 264 0 None closed [release-4.4] Bug 1813374: cache the client based on the endpoints to avoid reconstruction 2021-01-07 03:13:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:46:48 UTC

Description Suresh Kolichala 2020-03-13 15:44:17 UTC
+++ This bug was initially created as a clone of Bug #1813373 +++

Description of problem:
May reduce log noise too while improving the performance.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install cluster
2. Watch the cluster-etcd-operator logs
3.

Actual results:
A lot of periodic construction of etcd client.

Expected results:
Reuse etcd client object if endpoints haven't changed.

Additional info:

Comment 3 ge liu 2020-03-20 06:46:27 UTC
Verified with 4.4 0318, checked the commit have been merged into the build, and without regression err.

Comment 5 errata-xmlrpc 2020-05-04 11:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.