Bug 1813489 - The Upgradeable status of "service-catalog-apiserver" is "Unknown" before enable it
Summary: The Upgradeable status of "service-catalog-apiserver" is "Unknown" before ena...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Jesus M. Rodriguez
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks: 1813488
TreeView+ depends on / blocked
 
Reported: 2020-03-14 01:36 UTC by Fan Jia
Modified: 2020-05-04 11:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Upgradeable field was not being properly set by the Service Catalog Operators. Consequence: Upgradeable field would appear as Unknown after a fresh cluster install. Fix: The Upgradeable field was properly set by the Service Catalog Operators when they are first run. And subsequently through the various management states. Result:
Clone Of: 1812047
Environment:
Last Closed: 2020-05-04 11:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:46:48 UTC

Description Fan Jia 2020-03-14 01:36:31 UTC
Description of problem:
The Upgradeable status of "service-catalog-apiserver" is "Unknown" before enable it.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-09-205007

How reproducible:
always

Steps to Reproduce:
1.Install the cluster
2. check the clusteropeators "service-catalog-apiserver" status
#oc get clusteropeators service-catalog-apiserver -o yaml

Actual results:
1. the Upgradeable status of "service-catalog-apiserver" is "Unknown"
#oc get clusteropeators service-catalog-apiserver -o yaml
status:
  conditions:
  ...
  - lastTransitionTime: "2020-03-10T02:37:48Z"
    reason: NoData
    status: Unknown
    type: Upgradeable

Expected results:
1. The Upgradeable status should be "True" or "False"

Additional info:
If you enable the "service-catalog-apiserver" the Upgradeable status will be "True".

Comment 3 Jesus M. Rodriguez 2020-04-08 21:37:43 UTC
Seems fixed for both of the service catalog operators in 4.4.0-rc.6

Comment 4 Jesus M. Rodriguez 2020-04-08 21:37:53 UTC
[jesusr@camaro deploy]$ oc get clusteroperators service-catalog-apiserver -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2020-04-08T21:12:10Z"
  generation: 1
  name: service-catalog-apiserver
  resourceVersion: "3780"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-apiserver
  uid: 13302264-c3b8-4460-a4a5-3569bc67cb35
spec: {}
status:
  conditions:
  - lastTransitionTime: "2020-04-08T21:12:12Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2020-04-08T21:12:12Z"
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2020-04-08T21:12:12Z"
    message: 'Available: the apiserver is in the desired state (Removed).'
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2020-04-08T21:12:12Z"
    message: 'Upgradeable: the apiserver is in a removed state, upgrades are possible.'
    reason: AsExpected
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-config
    resource: namespaces
  - group: ""
    name: openshift-config-managed
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-apiserver-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-apiserver
    resource: namespaces
  - group: apiregistration.k8s.io
    name: v1beta1.servicecatalog.k8s.io
    resource: apiservices
  versions:
  - name: operator
    version: 4.4.0-rc.6

Comment 5 Jesus M. Rodriguez 2020-04-08 21:38:07 UTC
[jesusr@camaro deploy]$ oc get clusteroperators service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2020-04-08T21:12:08Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "3422"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: 501250b9-9bd9-41cc-a090-8090180df8e7
spec: {}
status:
  conditions:
  - lastTransitionTime: "2020-04-08T21:12:08Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2020-04-08T21:12:08Z"
    message: 'Progressing: the controller manager is in a removed state, therefore
      no changes are being applied.'
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2020-04-08T21:12:08Z"
    message: 'Available: the controller manager is not initially installed, operator
      is available, switch to Managed to enable.'
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2020-04-08T21:12:08Z"
    message: 'Upgradeable: the controller manager is in a removed state, upgrades
      are possible.'
    reason: AsExpected
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: operator.openshift.io
    name: cluster
    resource: servicecatalogcontrollermanagers
  - group: ""
    name: openshift-service-catalog-controller-manager-operator
    resource: namespaces
  - group: ""
    name: openshift-service-catalog-controller-manager
    resource: namespaces
  versions:
  - name: operator
    version: 4.4.0-rc.6

Comment 6 Fan Jia 2020-04-09 02:02:49 UTC
test result:
cv: 4.4.0-0.nightly-2020-04-07-130324

$ oc get clusteroperators service-catalog-controller-manager -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2020-04-09T01:34:20Z"
  generation: 1
  name: service-catalog-controller-manager
  resourceVersion: "3314"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-controller-manager
  uid: 06906808-170c-4f1c-af86-fce087ed3d29
spec: {}
status:
  conditions:
  - lastTransitionTime: "2020-04-09T01:34:20Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2020-04-09T01:34:20Z"
    message: 'Progressing: the controller manager is in a removed state, therefore
      no changes are being applied.'
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2020-04-09T01:34:20Z"
    message: 'Available: the controller manager is not initially installed, operator
      is available, switch to Managed to enable.'
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2020-04-09T01:34:20Z"
    message: 'Upgradeable: the controller manager is in a removed state, upgrades
      are possible.'
    reason: AsExpected
    status: "True"
    type: Upgradeable

$ oc get clusteroperators service-catalog-apiserver -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2020-04-09T01:34:25Z"
  generation: 1
  name: service-catalog-apiserver
  resourceVersion: "3808"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/service-catalog-apiserver
  uid: d32b0825-ef67-4964-8a10-189f1baebe6b
spec: {}
status:
  conditions:
  - lastTransitionTime: "2020-04-09T01:34:26Z"
    reason: AsExpected
    status: "False"
    type: Degraded
  - lastTransitionTime: "2020-04-09T01:34:26Z"
    reason: AsExpected
    status: "False"
    type: Progressing
  - lastTransitionTime: "2020-04-09T01:34:26Z"
    message: 'Available: the apiserver is in the desired state (Removed).'
    reason: AsExpected
    status: "True"
    type: Available
  - lastTransitionTime: "2020-04-09T01:34:26Z"
    message: 'Upgradeable: the apiserver is in a removed state, upgrades are possible.'
    reason: AsExpected
    status: "True"
    type: Upgradeable

Comment 9 errata-xmlrpc 2020-05-04 11:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.