Bug 1814151 - /usr/lib64/libnsl.so.1 symlink no longer exists in RHEL 8.1 (compared to prior releases)
Summary: /usr/lib64/libnsl.so.1 symlink no longer exists in RHEL 8.1 (compared to prio...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libnsl2
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Filip Januš
QA Contact: RHEL CS Apps Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-17 08:33 UTC by purana
Modified: 2020-04-09 02:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-09 02:40:05 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description purana 2020-03-17 08:33:03 UTC
Description of problem:

libnsl.so.1 no longer exists in RHEL 8.1 (or CentOS 8.x)

/usr/lib64/libnsl.so1 no longer exists, and in prior RHEL and CentOS releases. i.e 7.4 /usr/lib64/libnsl.so.1 did exist as shown below;


Version-Release number of selected component (if applicable):

8.1

libnsl2-1.2.0-2.20180605git4a062cf.el8.x86_64

How reproducible:

Default RHEL 8.1 install - Server with GUI.

Contents of /usr/lib64 filtered by libnsl looks like below;

[root@rhel81 lib64]# ls -la libnsl*
lrwxrwxrwx. 1 root root     15 Aug 12  2018 libnsl.so.2 -> libnsl.so.2.0.0
-rwxr-xr-x. 1 root root 116408 Aug 12  2018 libnsl.so.2.0.0

Applications built to depend on libnsl.so.1 fail to execute due to missing library. 

Applications run fine on previous RHEL/CentOS releases like CentOS 7.6 because libnsl.so.1 exists as a symlink (as shown below);

[root@centos74fs lib64]# ls -la libnsl*
-rwxr-xr-x. 1 root root 113584 Aug  2  2017 libnsl-2.17.so
lrwxrwxrwx. 1 root root     14 Oct 30 13:16 libnsl.so.1 -> libnsl-2.17.so


Expected results:

I expected /usr/lib64/libnsl.so.1 to exist and point to libnsl.so.2.0.0 on RHEL 8.1 (and CentOS 8.x) releases. Like it did in previous OS releases. Why did we drop the symlink.

Additional info:

I noticed this problem impacts numerous software packages built to use libnsl.so.1

i.e.

VMware Workstation - https://bugzilla.redhat.com/show_bug.cgi?id=1715405

and

NetBackup - https://www.veritas.com/support/en_US/article.100045645

It also impacts Commvault 11 Linux x64 installation scripts which binaries during the installation that also need libnsl.so.1

We really shouldn't expect the users to create the symlink that existed in prior OS releases, which will work around the problem.

Comment 1 Filip Januš 2020-03-17 13:46:46 UTC
I haven't found problem with links. There is problem with two libraries with similar name. In RHEL8.x we can find libnsl which provides link libnsl.so.1 -> libnsl-2.17.so and other library libnsl2 which provides libnsl.so.2 -> libnsl.so.2.0.0. I don't know what are you trying to install, but to fix this issue is only nessesary to set up right dependency. Or install libnsl manualy by using dnf install libnsl

Comment 2 purana 2020-03-17 21:54:47 UTC
In simple terms I want libnsl.so.1 to be present in /usr/lib64 (either by installing an rpm package that contains it - none do) or having one of the existing packages libnsl2-dev or libnsl2-1.2.0-2.20180605git4a062cf.el8.x86_64 to contain a %post task that symlinks libnsl.so.1 to libnsl.so.2.0.0

My point was, that this existed in prior release that I checked - which I had on hand (7.6), so can't we address it and just have it generated by one of the package installs, so end users don't need to manually create the symlink for applications that are expecting to see /usr/lib64/libnsl.so.1

Comment 3 purana 2020-03-17 23:14:42 UTC
Please close this bug report. No further assistance required.

I've been able to conclude and determine that when you install libnsl-2.28-72.el8.x86_64.rpm - it will generate the /usr/lib64/libnsl.so.1 symlink to the newly installed  /usr/lib64/libnsl-2.28.so

Comment 4 amit yadav 2020-04-09 02:40:05 UTC
(In reply to purana from comment #3)
> Please close this bug report. No further assistance required.
> 
> I've been able to conclude and determine that when you install
> libnsl-2.28-72.el8.x86_64.rpm - it will generate the /usr/lib64/libnsl.so.1
> symlink to the newly installed  /usr/lib64/libnsl-2.28.so

That's correct. Closing this bug as per #3


Note You need to log in before you can comment on or make changes to this bug.