Bug 1814192 - "Skipping packages with conflicts" should not be green
Summary: "Skipping packages with conflicts" should not be green
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Mach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-17 10:32 UTC by Miro Hrončok
Modified: 2020-05-01 04:04 UTC (History)
9 users (show)

Fixed In Version: dnf-4.2.21-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-01 04:04:42 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of the problem (49.65 KB, image/png)
2020-03-17 10:32 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2020-03-17 10:32:31 UTC
Created attachment 1670778 [details]
Screenshot of the problem

Description of problem:
When there are packages with conflicts, dnf shows them in green. That contradicts any common perception of the green color (means success).

Version-Release number of selected component (if applicable):
dnf-4.2.19-1.fc32.noarch

How reproducible: Run a transaction with conflict


Actual results:
"Skipping packages with conflicts" section lists green packages.

Expected results:
"Skipping packages with conflicts" section lists packages in other color, possibly red or magenta.

Additional info:
See the attached screenshot.

Comment 1 Daniel Mach 2020-03-25 10:36:15 UTC
I removed the misleading green color:
PR: https://github.com/rpm-software-management/dnf/pull/1609

We'll probably have to rework using the colors,
because as you suggested, colors are frequently associated with success/failure
rather than any actions.

Comment 2 Fedora Update System 2020-04-09 10:56:50 UTC
FEDORA-2020-68aa5586ed has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-68aa5586ed

Comment 3 Fedora Update System 2020-04-09 18:40:18 UTC
FEDORA-2020-68aa5586ed has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-68aa5586ed`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-68aa5586ed

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-05-01 04:04:42 UTC
FEDORA-2020-68aa5586ed has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.