Bug 181427 - Boot not able to load LVM Volume Groups after kernel update
Boot not able to load LVM Volume Groups after kernel update
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: LVM and device-mapper development team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 17:27 EST by Ken Morehouse
Modified: 2010-05-14 18:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-14 18:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from mkinitrd -v (1.70 KB, text/plain)
2006-02-15 14:08 EST, Ken Morehouse
no flags Details

  None (edit)
Description Ken Morehouse 2006-02-13 17:27:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
I installed RHEL AS release 4 Update 2, creating a LVM volume group and logical volumes on top of a 3ware 9550SX SATA RAID controller. 
After installation, bootup and volumes work fine.
Ran up2date to update the kernel from 2.6.9-22.ELsmp to 2.6.9-22.0.2.ELsmp. Update went fine, until I rebooted the system. 
The system now fails to boot after failing to locate volume group vg00.

Exact error display of system after kernel panic is:
Booting 'Red Hat Enterprise Linux AS (2.6.9-22.0.2.ELsmp)'
kernel direct mapping tables upto 10100000000 @ 8000-d000
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.9-22.0.2.ELsmp ro root=/dev/vg00/lgv_root rhgb quiet
   [Linux-bzImage, setup=0x1400, size=0x19043f]
initrd /initrd-2.6.9-22.0.2.ELsmp.img
   [Linux-initrd @ 0x37e6c000, 0x183a9d bytes]


.
Decompressing Linux...done.
Booting the kernel.
Red Hat nash version 4.2.1.6 starting
  Reading all physical volumes.  This may take a while...
  No volume groups found
  Unable to find volume group "vg00"
ERROR: /bin/lvm exited abnormally! (pid 219)
mount: error 6 mounting ext3
mount: error 2 mounting none
swicthroot: mount failed : 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!



Version-Release number of selected component (if applicable):
lvm2-2.01.14-2.0.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. Update kernel to latest version via up2date
2. Reboot and select the latest build via Grub
  

Actual Results:  See description.

Additional info:
Comment 1 Ken Morehouse 2006-02-13 17:30:29 EST
Contents of modprobe.conf (Works fine with 2.6.9-22.ELsmp)

alias scsi_hostadapter 3w-9xxx
alias eth0 tg3
alias eth1 tg3
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
Comment 2 Nate Straz 2006-02-14 09:22:52 EST
Could you also tell us the filter line in /etc/lvm/lvm.conf?
Try booting without the "quiet" option.  Do you see your 3ware 9550SX and
the disks attached in the boot messages?
Comment 3 Ken Morehouse 2006-02-14 10:05:16 EST
I am away from the office today, but will get this information for you tomorrow.
From memory, I did enable extended logging for lvm. I will collect that log and
attach tomorrow.
Comment 4 Ken Morehouse 2006-02-15 08:34:40 EST
The filter line from lvm.conf is 
filter = [ "a/.*/" ]

The disks appear to be loading properly. Unfortunately, the boot sequence
happens so fast that I can't view the disk loading sequence to verify.
Comment 5 Ken Morehouse 2006-02-15 08:36:42 EST
What I'm going to do for now is to restructure the partitions so that only /home
and /var are contained within LVM. At least I should be able to boot the server
to single user with the latest kernel loaded.
Comment 6 Ken Morehouse 2006-02-15 12:58:04 EST
After reinstalling without using LVM on any partition, except /home and /var, I
still get a kernel panic after updating via RHN.

I booted without the quiet flag and here is what I can see during boot prior to
the panic. Could this have something to do with the device-mapper?

1) Loading 3-9xxx.ko module
2) 3ware 9000 Storage Controller device driver for Linux v2.26.02.001
3) Loading dm-mod.ko module
4) device-mapper : 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
5) Loading jbd.ko module
6) Loading ext3.ko module
7) Creating root device
8) mkrootdev: label / not found
9) Mounting root filesystem
10) mount: error 2 mounting ext3
11) mount: error 2 mounting none
12) Switching to new root
13) switchroot: mount failed: 22
14) umount /initrd/dev failed: 2
15) Kernel panic - not syncing: Atrtempted to kill init!
Comment 7 Nate Straz 2006-02-15 13:08:34 EST
Does the root device show up at /dev/sd? when you're booted?
Is sd_mod getting loaded during your initrd?
Try rerunning the mkinitrd command with the -v flag and post that output to the bug.
Comment 8 Ken Morehouse 2006-02-15 13:47:46 EST
1) Unfortunately, I do not get beyond the kernel panic.
2) I don't see anything related to sd_mod during the bootstrap. It may be
loading, but the screen output is so fast, I may be missing it.
3) I will attempt the mkinitrd and send the output to you.

One thing, though. I have found numerous postings that reference this error with
an issue with using a LABEL for the root device in GRUB. Could this potentially
have an impact here? 
This is my GRUB entry for this kernel: kernel /vmlinuz-2.6.9-22.0.2.EL ro
root=LABEL=/ rhgb

Comment 9 Ken Morehouse 2006-02-15 14:08:55 EST
Created attachment 124701 [details]
Output from mkinitrd -v
Comment 10 Nate Straz 2006-02-17 11:48:27 EST
When you filed the bug you said you were booting with the option
"root=/dev/vg00/lgv_root," does it boot with that now instead of using
"root=LABEL=/?"
Comment 11 Ken Morehouse 2006-03-24 11:13:06 EST
It has been awhile since attempting. To my recollection, I was not able to get
that to work.
Comment 12 Milan Broz 2010-05-14 18:11:39 EDT
Quite old bug and according to comments, still not enough information why it failed (mkinitrd?)... Closing this, please reopen if you have still problems on more recent system, thanks.

Note You need to log in before you can comment on or make changes to this bug.