Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1814292 - Copy DR scripts from etcd-scripts to /usr/local/bin for convenience
Summary: Copy DR scripts from etcd-scripts to /usr/local/bin for convenience
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1814290
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-17 15:01 UTC by Suresh Kolichala
Modified: 2020-05-04 11:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1814290
Environment:
Last Closed: 2020-05-04 11:46:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 269 0 None closed [release-4.4] Bug 1814292: Copy files from etcd-scripts to /usr/local/bin for convenience 2020-06-30 20:10:36 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:47:00 UTC

Description Suresh Kolichala 2020-03-17 15:01:35 UTC
+++ This bug was initially created as a clone of Bug #1814290 +++

Description of problem:
The latest DR scripts are generated by cluster-etcd-operator in the directory of /etc/kubernetes/static-pod-resources/etcd-certs/configmaps/etcd-scripts/. For easy invocation of these scripts for recovery, they should be copied to /usr/local/bin directory.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install 4.4.
2.
3.

Actual results:
The recovery scripts are not in /usr/local/bin.

Expected results:
The scripts are available in a directory that is included in the default PATH.

Additional info:

Comment 5 errata-xmlrpc 2020-05-04 11:46:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.