Bug 1814356 - Different results on x86_64 and i686
Summary: Different results on x86_64 and i686
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: doxygen
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1799468
TreeView+ depends on / blocked
 
Reported: 2020-03-17 17:24 UTC by Jaroslav Škarvada
Modified: 2020-09-29 00:15 UTC (History)
2 users (show)

Fixed In Version: doxygen-1.8.20-4.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-29 00:15:27 UTC
Type: Bug


Attachments (Terms of Use)
Reproducer (8.80 MB, application/gzip)
2020-03-17 17:25 UTC, Jaroslav Škarvada
no flags Details


Links
System ID Priority Status Summary Last Updated
Github doxygen doxygen issues 8022 None open Different results on 64 and 32 bit 2020-09-29 03:24:56 UTC

Description Jaroslav Škarvada 2020-03-17 17:24:04 UTC
Description of problem:
It generates different graphs on x86_64 and i386.

Version-Release number of selected component (if applicable):
doxygen-1.8.17-2.fc32

How reproducible:
Always

Steps to Reproduce:
1. Download the reproducer to /var/tmp
2. cd /var/tmp
3. tar -xzf ./gr-fcdproplus.tar.gz
4. cd gr-fcdproplus/build/docs/doxygen
5. doxygen ./Doxyfile
6. find -name 'inherit_graph_*.png'

Actual results:
On x86_64:
./html/inherit_graph_0.png
./html/inherit_graph_1.png

On i686:
./html/inherit_graph_0.png
./html/inherit_graph_1.png
./html/inherit_graph_3.png
./html/inherit_graph_2.png

Expected results:
Consistent results on all arches

Additional info:
It's the same on the other arches as well (it seems to be 32/64 bit problem).

It seems to be an regression, with the doxygen-1.8.15-6.fc30 the results are consistent.

Comment 1 Jaroslav Škarvada 2020-03-17 17:25:52 UTC
Created attachment 1670893 [details]
Reproducer

Comment 2 Jaroslav Škarvada 2020-03-17 17:27:06 UTC
It's blocking gr-fcdproplus rebuilt. I will workaround the problem by making the docs subpackage arch.

Comment 3 Ben Cotton 2020-08-11 13:14:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 4 Mattias Ellert 2020-09-12 20:54:25 UTC
Fixed in upstream git:

https://github.com/doxygen/doxygen/commit/1fda77f54a2eacba32658001329bd9084f4df1e7?branch=1fda77f54a2eacba32658001329bd9084f4df1e7&diff=unified

Please consider fixing in F32+. This regression is very disruptive.

Comment 5 Fedora Update System 2020-09-17 10:10:18 UTC
FEDORA-2020-58e49c555a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-58e49c555a

Comment 6 Fedora Update System 2020-09-17 17:55:02 UTC
FEDORA-2020-58e49c555a has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-58e49c555a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-58e49c555a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-09-17 19:40:27 UTC
FEDORA-2020-58e49c555a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-58e49c555a

Comment 8 Fedora Update System 2020-09-18 18:58:55 UTC
FEDORA-2020-58e49c555a has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-58e49c555a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-58e49c555a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-09-29 00:15:27 UTC
FEDORA-2020-58e49c555a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.