Bug 1814370 - gnome-clocks won't add a new world clock
Summary: gnome-clocks won't add a new world clock
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-clocks
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gnome-sig
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-17 17:40 UTC by Geoffrey Marr
Modified: 2020-05-21 15:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-21 15:57:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Geoffrey Marr 2020-03-17 17:40:40 UTC
Description of problem:
Boot fresh install of F32 workstation beta. Click on time icon at top middle of screen. Click "Add World Clock". Attempt to search for city/country in "Add a New World Clock" box, box does not auto-populate with city/country and user cannot select "Add" until it does.

Version-Release number of selected component (if applicable):
gnome-clocks-3.36.0-1.fc32.src.rpm

How reproducible:
Always

Additional info:
gnome-clocks-3.36.0-1.fc32.src.rpm

Comment 1 Geoffrey Marr 2020-03-17 17:56:12 UTC
Want to add:

Click on time icon at top middle of screen. Click "Add World Clock".***Click the "+" in the top left of the screen that pops up.*** Attempt to search for city/country in "Add a New World Clock" box, box does not auto-populate with city/country and user cannot select "Add" until it does.

Comment 2 Fedora Blocker Bugs Application 2020-03-17 18:05:48 UTC
Proposed as a Blocker for 32-final by Fedora user coremodule using the blocker tracking app because:

 A possible violation of the following F32 Final criterion: "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test."

Comment 3 Michael Catanzaro 2020-03-22 22:48:47 UTC
Works for me, so -1 blocker.

The autocompletion triggers some nasty graphical glitches, but that's not a F32 regression.

Comment 4 Lukas Ruzicka 2020-03-23 16:33:45 UTC
The above mentioned version of Clocks works on my machine - it starts with just an empty line, but when I start typing I get a list of suggestions and that works just fine.

Comment 5 Geoffrey Marr 2020-03-23 19:32:55 UTC
Discussed during the 2020-03-23 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker" was made as we only have one system that hits this out of 5 or 6 that have tried, so it doesn't seem widespread enough to justify blocker status. We are open to reconsider if more information emerges.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-23/f32-blocker-review.2020-03-23-16.00.txt


Note You need to log in before you can comment on or make changes to this bug.