Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1814479 - [DR] calls to etcdctl should use the container running on host
Summary: [DR] calls to etcdctl should use the container running on host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks: 1814581
TreeView+ depends on / blocked
 
Reported: 2020-03-18 01:25 UTC by Sam Batschelet
Modified: 2020-07-13 17:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1814581 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:22:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 268 0 None closed Bug 1814479: bindata/etcd: run etcdctl inside of container 2020-06-30 13:48:56 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:22:45 UTC

Description Sam Batschelet 2020-03-18 01:25:52 UTC
Description of problem: we currently are extracting an etcdctl image and executing. Since we have a running container with proper certs on host we should use that instead.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: etcdctl is a local binary used by DR


Expected results: exec into etcdctl container and run command.


Additional info:

Comment 6 errata-xmlrpc 2020-07-13 17:22:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.