Bug 1814553 - Refrain from showing up the read-only fields in HC cockpit deployment wizard
Summary: Refrain from showing up the read-only fields in HC cockpit deployment wizard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.8
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1814554
Blocks: RHHI-V-1.8-Engineering-Inflight-BZs
TreeView+ depends on / blocked
 
Reported: 2020-03-18 08:41 UTC by SATHEESARAN
Modified: 2020-08-04 14:52 UTC (History)
1 user (show)

Fixed In Version: cockpit-ovirt-0.14.3-1.el8ev
Doc Type: Enhancement
Doc Text:
Read-only fields are no longer included in the web console user interface, making the interface simpler and easier to read.
Clone Of:
: 1814554 (view as bug list)
Environment:
Last Closed: 2020-08-04 14:52:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:3314 0 None None None 2020-08-04 14:52:21 UTC

Description SATHEESARAN 2020-03-18 08:41:07 UTC
Description of problem:
------------------------
There are few fields which need not be shown in the cockpit deployment wizard UI, to make it less complex and helpful for customers to make quick judgement.

1. thinp checkbox in bricks tab
All bricks except 'engine' brick are thinp, engine brick is thick.
We do not allow users to modify it.

2.  Mount point of the brick
This is also the read-only value, generated based on the 'brick path' value' input from previous tab

3. Logical size of the brick
When VDO is used the size of the brick is 10 times the physical size of the brick.
Again this is a fixed value, read-only


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
cockpit-ovirt-dashboard-0.14.2

How reproducible:
-----------------
Always

Expected results:
-----------------
Remove the read-only fields - thinp, mount point of the brick and logical size of the brick

Comment 2 SATHEESARAN 2020-03-30 14:44:12 UTC
The dependent bug is moved ON_QA

Comment 3 SATHEESARAN 2020-03-30 14:44:41 UTC
Tested with cockpit-ovirt-dashboard-0.14.3

The read-only fields in bricks tab - thinp checkbox, mount point of the brick and logical size of the brick - 
are hiddend and not exposed

Comment 5 errata-xmlrpc 2020-08-04 14:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHHI for Virtualization 1.8 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:3314


Note You need to log in before you can comment on or make changes to this bug.