Bug 1814588 - ceph-ansible fails with "you must set dashboard_admin_password and grafana_admin_password."
Summary: ceph-ansible fails with "you must set dashboard_admin_password and grafana_a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: z2
: 16.0 (Train on RHEL 8.1)
Assignee: Francesco Pantano
QA Contact: Nathan Weinberg
URL:
Whiteboard:
Depends On:
Blocks: 1790754
TreeView+ depends on / blocked
 
Reported: 2020-03-18 10:33 UTC by Francesco Pantano
Modified: 2020-05-14 12:16 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-11.3.2-0.20200324120625.c3a8eb4.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-14 12:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
ceph-ansible execution (1.70 MB, text/plain)
2020-03-18 14:46 UTC, Francesco Pantano
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1867973 0 None None None 2020-03-19 15:46:48 UTC
OpenStack gerrit 713706 0 None MERGED Move ceph-ansible required variables in the main group 2020-06-18 12:20:15 UTC
OpenStack gerrit 713959 0 None MERGED Move ceph-ansible required variables in the main group 2020-06-18 12:20:15 UTC
Red Hat Product Errata RHBA-2020:2114 0 None None None 2020-05-14 12:16:36 UTC

Description Francesco Pantano 2020-03-18 10:33:35 UTC
Description of problem:

During the overcloud deployment with ceph dashboard enabled, the playbook fails during the execution of "ceph-validate" role. In particular, the task that double check that both grafana and dashboard admin password are set fails.
Passing the dashboard related template (-e /usr/share/openstack-tripleo-heat-templates/environment/ceph-dashboard.yaml) to the overcloud, we can see all the expected parameters in ceph-ansible workdir are set (included grafana and dashboard admin credentials).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Francesco Pantano 2020-03-18 14:46:26 UTC
Created attachment 1671139 [details]
ceph-ansible execution

Comment 15 errata-xmlrpc 2020-05-14 12:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2114


Note You need to log in before you can comment on or make changes to this bug.