Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1814621 - openshift-apiserver-operator spams update events
Summary: openshift-apiserver-operator spams update events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Stefan Schimanski
QA Contact: Ke Wang
URL:
Whiteboard:
: 1813919 (view as bug list)
Depends On: 1814618
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-18 11:58 UTC by Standa Laznicka
Modified: 2020-05-04 11:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1814618
Environment:
Last Closed: 2020-05-04 11:46:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:47:00 UTC

Description Standa Laznicka 2020-03-18 11:58:14 UTC
+++ This bug was initially created as a clone of Bug #1814618 +++

Description of problem:
wrong comparison of values of different types causes update event to be announced even if the values did not change

Logs:
...
I0316 13:48:15.338406       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:16.338521       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:17.338679       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:18.338827       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:19.338948       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:20.338980       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:21.339221       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:22.339413       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:23.339501       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:24.339619       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
I0316 13:48:25.339752       1 event.go:281] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-apiserver-operator", Name:"openshift-apiserver-operator", UID:"10e44167-910d-40b9-b62a-6ae927ecb165", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'ObserveStorageUpdated' Updated storage urls to https://10.0.130.223:2379,https://10.0.134.12:2379,https://10.0.144.238:2379
...

Comment 3 Standa Laznicka 2020-03-23 09:26:03 UTC
*** Bug 1813919 has been marked as a duplicate of this bug. ***

Comment 4 Ke Wang 2020-04-02 05:23:16 UTC
Verified with the foloowing OCP 4.4 build, 

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-04-01-213929   True        False         118m    Cluster version is 4.4.0-0.nightly-2020-04-01-213929

Verification steps,
oc logs -n openshift-apiserver-operator deployment/openshift-apiserver-operator | grep -i 'ObserveStorageUpdated' 

Nothing found for above mentioned log.

Comment 6 errata-xmlrpc 2020-05-04 11:46:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.