Bug 1814639 - The content of the tiles in the Developer Catalog is not accurate
Summary: The content of the tiles in the Developer Catalog is not accurate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: ralpert
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1814807
TreeView+ depends on / blocked
 
Reported: 2020-03-18 12:18 UTC by Serena
Modified: 2020-07-13 17:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Someone had set the tile description variable to be the CRD description appended with the CSV description. This caused the tile descriptions to be wrong. I set the tile description back to its original value and moved the appended value to its own variable. This fixed the issue.
Clone Of:
: 1814807 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:22:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dev Catalog tiles are incorrect - should not append the Operator Description (348.27 KB, image/png)
2020-03-18 12:18 UTC, Serena
no flags Details
Tiles on the Installed Operator side seem fine (394.02 KB, image/png)
2020-03-18 12:20 UTC, Serena
no flags Details
No ## in the description (137.36 KB, image/png)
2020-03-23 05:23 UTC, Gajanan More
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4764 None closed Bug 1814639: Refactor description used for DevCatalog 2020-06-30 18:22:46 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:23:02 UTC

Description Serena 2020-03-18 12:18:24 UTC
Created attachment 1671033 [details]
Dev Catalog tiles are incorrect - should not append the Operator Description

Description of problem:

The tiles in the Developer Catalog should only be showing the CRD description.  It looks like it is appending the Operator Description as well, which is incorrect.


Version-Release number of selected component (if applicable):


How reproducible:
Go to Dev Perspective, go to Add page, click on Catalog, make sure Operator Backed is selected, and look at the tiles ( screenshot included ).

Notice this is not occurring on the tiles in the Installed Operators page.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Serena 2020-03-18 12:20:06 UTC
Created attachment 1671034 [details]
Tiles on the Installed Operator side seem fine

Adding a screenshot of Installed Operator Side.  This is correct, in that it only shows the CRD Description.

Comment 2 Serena 2020-03-18 12:21:48 UTC
Assigning to Rebecca, since she's done a lot of work here in the past.

Comment 6 Gajanan More 2020-03-23 05:23:51 UTC
Created attachment 1672538 [details]
No ## in the description

Comment 7 Gajanan More 2020-03-23 05:25:16 UTC
I have validated this bug on
Build: 4.5.0-0.nightly-2020-03-22-224936
Browser: Google Chrome Version 78.0.3904.108
Marking this as done.
Please have a look at the shared screenshot.

Comment 9 errata-xmlrpc 2020-07-13 17:22:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.