Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1814676 - Calendar is not displayed as default calendar application in GNOME Settings
Summary: Calendar is not displayed as default calendar application in GNOME Settings
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-calendar
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Raits
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-18 14:06 UTC by Daniel Rusek
Modified: 2020-10-06 12:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-06 12:18:57 UTC
Type: Bug


Attachments (Terms of Use)
Default applications (20.42 KB, image/png)
2020-03-18 14:06 UTC, Daniel Rusek
no flags Details

Description Daniel Rusek 2020-03-18 14:06:34 UTC
Created attachment 1671078 [details]
Default applications

Description of problem:
The Calendar application is not displayed as default calendar application in GNOME Settings on latest Fedora 32 Beta. Text Editor is displayed there instead. See the attached screenshot.

Version-Release number of selected component (if applicable):
gnome-calendar-3.36.0-1.fc32.x86_64
gnome-control-center-3.36.0-2.fc32.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Open GNOME Settings.
2. Switch to "Default applications".

Actual results:
"Text Editor" is the only default calendar application available.

Expected results:
"Calendar" is the default calendar application.

Comment 1 Peter Simonyi 2020-04-24 03:27:58 UTC
The default calendar application option changes the handler for ICS calendar files.  (Also, afaik, it does nothing else.)  Since Gnome Calendar doesn't handle ICS files, upstream devs don't think it's appropriate to offer it as a default calendar application in Gnome Settings.  Perhaps the real bug is offering a "default calendar app" when it really means "default ICS file handler"?

Upstream has several closed bugs discussing the issue, e.g.:

https://gitlab.gnome.org/GNOME/gnome-calendar/-/issues/337
https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/804
https://gitlab.gnome.org/GNOME/gnome-calendar/-/issues/375

The upstream bug for handling ICS files is https://gitlab.gnome.org/GNOME/gnome-calendar/-/issues/5

Comment 2 Daniel Rusek 2020-10-06 12:18:57 UTC
I am closing this ticket since this is a well known upstream issue.


Note You need to log in before you can comment on or make changes to this bug.