SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1814712 - ovnkube-master leader apparently logs more than INFO level
Summary: ovnkube-master leader apparently logs more than INFO level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Alexander Constantinescu
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On: 1822215
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-18 14:44 UTC by Anurag saxena
Modified: 2020-05-04 11:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1822215 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:46:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 132 None closed Bug 1814712: Removing node bring up debug log level 2020-04-13 13:54:11 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:47:00 UTC

Comment 1 Dan Winship 2020-03-18 14:56:13 UTC
This is probably https://github.com/ovn-org/ovn-kubernetes/pull/1139 (fixed upstream but not merged into our builds yet).

Comment 2 Anurag saxena 2020-03-18 15:12:33 UTC
@Dan, So PR 1139 is trying to make level 5 as default. Aren't we supposed to stay at level 4(INFO) by default?
And apparently without this PR even, currently i see logs at level 5 but config set to 4.

Comment 3 Dan Winship 2020-03-18 15:18:10 UTC
The title of the PR is confusing... I don't really understand what it's supposed to be saying.

The problem is that we intentionally bump the log level up to 5 at startup time so that if something goes wrong we'll have sufficient logs about it. It's *supposed* to set the log level back down to the configured level after startup is complete, but that was broken. That's what the PR fixes.

Comment 4 Anurag saxena 2020-03-18 15:26:56 UTC
Make sense to me now @Dan. Thanks for clarifications.

Comment 5 Alexander Constantinescu 2020-03-20 12:38:53 UTC
@Dan

I doubt that this bug is related to:  https://github.com/ovn-org/ovn-kubernetes/pull/1139, that PR fixes an issue with ovnkube when klog was already activated. The logs Anurag attached show logrus still being used...

I think this problem is something that might have impacted ovnkube when logrus was activated, or something that might come to impact klog too. It's really strange that the log-level is not respected. 

/Alex

Comment 9 Ross Brattain 2020-04-15 10:53:03 UTC
Verified log level 4 (INFO) on 4.4.0-0.nightly-2020-04-15-071550

Comment 11 errata-xmlrpc 2020-05-04 11:46:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.