Bug 1814746 - Rebase NetworkManager to latest upstream version in RHEL 8.3
Summary: Rebase NetworkManager to latest upstream version in RHEL 8.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: NetworkManager Development Team
QA Contact: Desktop QE
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-18 15:37 UTC by Beniamino Galvani
Modified: 2020-11-04 21:28 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
.NetworkManager rebased to version 1.26.0 The `NetworkManager` packages have been upgraded to upstream version 1.26.0, which provides a number of enhancements and bug fixes over the previous version: * NetworkManager resets the auto-negotiation, speed, and duplex setting to their original value when deactivating a device. * Wi-Fi profiles connect now automatically if all previous activation attempts failed. This means that an initial failure to auto-connect to the network no longer blocks the automatism. A side effect is that existing Wi-Fi profiles that were previously blocked now connect automatically. * The `nm-settings-nmcli(5)` and `nm-settings-dbus(5)` man pages have been added. * Support for a number of bridge parameters has been added. * Support for virtual routing and forwarding (VRF) interfaces has been added. For further details, see link:https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/configuring_and_managing_networking/configuring-virtual-routing-and-forwarding-vrf_configuring-and-managing-networking#permanently-reusing-the-same-ip-address-on-different-interfaces_configuring-virtual-routing-and-forwarding-vrf[Permanently reusing the same IP address on different interfaces]. * Support for Opportunistic Wireless Encryption mode (OWE) for Wi-Fi networks has been added. * NetworkManager now supports 31-bit prefixes on IPv4 point-to-point links according to link:https://tools.ietf.org/html/rfc3021[RFC 3021]. * The `nmcli` utility now supports removing settings using the `nmcli connection modify <connection_name> remove <setting>` command. * NetworkManager no longer creates and activates slave devices if a master device is missing. For further information about notable changes, read the upstream release notes: * link:https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/blob/1.26.0/NEWS[NetworkManager 1.26.0] * link:https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/blob/1.24.0/NEWS[NetworkManager 1.24.0]
Clone Of:
Environment:
Last Closed: 2020-11-04 01:49:00 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4499 0 None None None 2020-11-04 01:49:28 UTC

Description Beniamino Galvani 2020-03-18 15:37:13 UTC
Rebase NM in RHEL 8.3 to the latest upstream version to pick up new features and recent fixes. This is safe to do as newer versions of NM never break API/ABI and guarantee backwards compatibility. The project also has an extensive CI suite to avoid regressions.

Comment 13 errata-xmlrpc 2020-11-04 01:49:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (NetworkManager bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4499


Note You need to log in before you can comment on or make changes to this bug.