Bug 1814968 - dnsmasq 2.80.12 does not resolve DNS queries against dhcp-host names
Summary: dnsmasq 2.80.12 does not resolve DNS queries against dhcp-host names
Keywords:
Status: CLOSED DUPLICATE of bug 1814468
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-19 07:31 UTC by Oleg Samarin
Modified: 2020-03-23 15:04 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-23 15:04:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Oleg Samarin 2020-03-19 07:31:57 UTC
Description of problem:

After upgrading dnsmasq from 2.80-10 to 2.80-12 it stopped resolve DNS queries against hostnames specified in dhcp-host lines. If a host name is specified in an address line, it is resolved properly.

After downgrading dnsmasq to 2.80-10, it started resolving dhcp-host names again.


Version-Release number of selected component (if applicable):

dnsmasq-2.80-12.fc31.x86_64


How reproducible:

Always


Steps to Reproduce:
1. edit dnsmasq.conf: specify dhcp-range and domain 'domain1'. Add a dhcp-host line for some existing mac address with the name 'name1' and some ip address ip.ip.ip.ip1
2. start dnsmasq
3. make the host with this mac address to receive the ip address ip.ip.ip.ip1 from dnsmasq
4. query dnsmasq with nslookup:

nslookup name1.domain1 localhost

Actual results:

** server can't find name1.domain1: NXDOMAIN


Expected results:

Name:	name1.domain1
Address: ip.ip.ip.ip1


Additional info:

Comment 1 Petr Menšík 2020-03-23 15:04:53 UTC

*** This bug has been marked as a duplicate of bug 1814468 ***


Note You need to log in before you can comment on or make changes to this bug.