Bug 181501 - unaligned accesses seen during mono execution
unaligned accesses seen during mono execution
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-02-14 12:58 EST by Prarit Bhargava
Modified: 2008-03-05 16:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 16:07:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-02-14 12:58:04 EST
Description of problem:  When mono executes on an ia64 box, unaligned  
access errors are generated. 
 
 
Version-Release number of selected component (if applicable):  latest nightly 
build 
 
 
How reproducible:  AFAICT, whenever mono runs we see unaligned accesses 
 
 
Steps to Reproduce: 
1. Install latest nightly 
2. Let system sit and monitor console. 
   
Actual results: 
 
After leaving a system running overnight, 
 
thetango.boston.redhat.com login: mono(28216): unaligned access to 
0x2000000001408071, ip=0x400000000014cea0 
mono(28216): unaligned access to 0x2000000001408075, ip=0x400000000014cee0 
mono(28216): unaligned access to 0x2000000001408079, ip=0x400000000014cea0 
mono(28216): unaligned access to 0x200000000140807d, ip=0x400000000014cee0 
mono(9297): unaligned access to 0x2000000001408071, ip=0x400000000014cea0 
mono(9297): unaligned access to 0x2000000001408075, ip=0x400000000014cee0 
mono(9297): unaligned access to 0x2000000001408079, ip=0x400000000014cea0 
mono(9297): unaligned access to 0x200000000140807d, ip=0x400000000014cee0 
mono(16216): unaligned access to 0x2000000001408071, ip=0x400000000014cea0 
mono(16216): unaligned access to 0x2000000001408075, ip=0x400000000014cee0 
mono(16216): unaligned access to 0x2000000001408079, ip=0x400000000014cea0 
mono(16216): unaligned access to 0x200000000140807d, ip=0x400000000014cee0 
mono(23070): unaligned access to 0x2000000001408071, ip=0x400000000014cea0 
mono(23070): unaligned access to 0x2000000001408075, ip=0x400000000014cee0 
mono(23070): unaligned access to 0x2000000001408079, ip=0x400000000014cea0 
mono(23070): unaligned access to 0x200000000140807d, ip=0x400000000014cee0 
mono(23711): unaligned access to 0x2000000001408071, ip=0x400000000014cea0 
mono(23711): unaligned access to 0x2000000001408075, ip=0x400000000014cee0 
mono(23711): unaligned access to 0x2000000001408079, ip=0x400000000014cea0 
mono(23711): unaligned access to 0x200000000140807d, ip=0x400000000014cee0 
mono(30609): unaligned access to 0x2000000001408071, ip=0x400000000014cea0 
mono(30609): unaligned access to 0x2000000001408075, ip=0x400000000014cee0 
mono(30609): unaligned access to 0x2000000001408079, ip=0x400000000014cea0 
mono(30609): unaligned access to 0x200000000140807d, ip=0x400000000014cee0 
 
 
Expected results: 
 
mono should not make unaligned accesses on ia64.  No warnings should be seen. 
 
Additional info:  I cannot get this to occur by running mono by hand. :(
Comment 1 Alexander Larsson 2006-02-17 09:39:50 EST
If you get it during the night, then it probably happens in
/usr/libexec/beagle-crawl-system which is run in a cronjob. You could run that
manually to verify this.
Comment 2 Prarit Bhargava 2006-02-23 13:40:43 EST
Hi Alexander, 
 
That seems to be causing the problem.  Executing beagle-crawl-system seems 
to cause the unaligned access messages.  I tried gdb'ing a prctl of 
beagle-crawl-system but wasn't able to get a good trace ... 
Comment 3 Doug Chapman 2008-03-05 16:07:58 EST
I have not seen this in the pre-F9 rawhide so closing it.  We will re-open and
provide some triage if we see it again.

Note You need to log in before you can comment on or make changes to this bug.