Bug 181507 - Advanced query page does not give product-specific versions
Advanced query page does not give product-specific versions
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
devel
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 13:37 EST by Stephen Tweedie
Modified: 2013-06-23 23:00 EDT (History)
0 users

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 15:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-02-14 13:37:17 EST
Description of problem:
Using the new bugzilla-devel, the simple bug query page gives me options in the
"version" listbox which match the appropriate versions for the selected item in
the "product" listbox.

The Advanced query page does not do this --- no matter which product is
selected, all possible versions of all possible products are listed.  Eg.
selecting fedora-core as the product, I still get to choose RHEL versions in the
version list box.

How reproducible:

100%

Steps to Reproduce:
1. Open https://bugzilla.redhat.com/bugzilla-devel/query.cgi?format=advanced

Actual results:
Version listbox contains every version of every product that has ever existed.

Expected results:
Version listbox should really only contain versions appropriate to the selected
product.
Comment 1 David Lawrence 2006-02-14 13:50:15 EST
Thank you for the feedback. This is actually expected since it mimics the
behaviour still of the old query page where you have to click 'Use Javascript'
in the upper right to enable the component/version filtering. This was
originally to allow people to load the page faster if they did not want the
extra overhead of the javascript code. The question now is whether I still need
to have those links at the upper right with the new Ajax method. I will remove
the links I think. Otherwise, does this work if you click the 'Use Javascript'
link first and then try to select a product?

Note You need to log in before you can comment on or make changes to this bug.