Bug 181510 - Cannot create/save files with eclipse
Cannot create/save files with eclipse
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 13:49 EST by Dawid Zamirski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 10:45:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dawid Zamirski 2006-02-14 13:49:39 EST
Description of problem:
Eclipse reports the following error message on every attempt to create or save a
file:
java.lang.NoClassDefFoundError:
org.eclipse.core.internal.utils.UniversalUniqueIdentifier


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.2-1jpp_7fc

How reproducible:
Always

Steps to Reproduce:
1. Create a new project or import existing project
2. Create a new file or open exisitng one and make some changes
3. Try to edit the new file or try to save the chenges in exsiting file
  
Actual results:
Eclipse throws the following error:
java.lang.NoClassDefFoundError:
org.eclipse.core.internal.utils.UniversalUniqueIdentifier
   at java.lang.Class.initializeClass (libgcj.so.7)
   at org.eclipse.core.internal.localstore.BlobStore.addBlob
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.localstore.HistoryStore2.addState
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.localstore.FileSystemResourceManager.write
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.resources.File.internalSetContents
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.resources.File.setContents
(org.eclipse.core.resources_3.1.2.jar.so)
   at
org.eclipse.core.internal.localstore.FileSystemResourceManager.internalWrite
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.resources.Project.writeDescription
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.resources.Project.setDescription
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.eclipse.core.internal.resources.Project.setDescription
(org.eclipse.core.resources_3.1.2.jar.so)
   at org.python.pydev.plugin.PythonNature.addNature (pydev.jar.so)
   at org.python.pydev.editor.PyDocumentProvider.createDocument (pydev.jar.so)
   at org.eclipse.ui.editors.text.FileDocumentProvider.createElementInfo
(org.eclipse.ui.editors_3.1.1.jar.so)
   at org.eclipse.ui.texteditor.AbstractDocumentProvider.connect
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.AbstractTextEditor.doSetInput
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.StatusTextEditor.doSetInput
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.AbstractDecoratedTextEditor.doSetInput
(org.eclipse.ui.editors_3.1.1.jar.so)
   at org.eclipse.ui.editors.text.TextEditor.doSetInput
(org.eclipse.ui.editors_3.1.1.jar.so)
   at org.eclipse.ui.texteditor.AbstractTextEditor$16.run
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.jface.operation.ModalContext.runInCurrentThread
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.operation.ModalContext.run (org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.window.ApplicationWindow$1.run
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.swt.custom.BusyIndicator.showWhile
(org.eclipse.swt.gtk.linux.x86_64_3.1.1.jar.so)
   at org.eclipse.jface.window.ApplicationWindow.run
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.ui.internal.WorkbenchWindow.run
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.AbstractTextEditor.internalInit
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.eclipse.ui.texteditor.AbstractTextEditor.init
(org.eclipse.ui.workbench.texteditor_3.1.2.jar.so)
   at org.python.pydev.editor.PyEdit.init (pydev.jar.so)
   at org.eclipse.ui.internal.EditorManager.createSite
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.EditorReference.createPartHelper
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.EditorReference.createPart
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.WorkbenchPartReference.getPart
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.EditorReference.getEditor
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.WorkbenchPage.access$9
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.WorkbenchPage$9.run
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.swt.custom.BusyIndicator.showWhile
(org.eclipse.swt.gtk.linux.x86_64_3.1.1.jar.so)
   at org.eclipse.ui.internal.WorkbenchPage.openEditor
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.WorkbenchPage.openEditor
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.ide.IDE.openEditor (org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.ide.IDE.openEditor (org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.actions.OpenFileAction.openFile
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.actions.OpenSystemEditorAction.run
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.views.navigator.OpenActionGroup.runDefaultAction
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.views.navigator.MainActionGroup.runDefaultAction
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.views.navigator.ResourceNavigator.handleOpen
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.ui.views.navigator.ResourceNavigator$6.open
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.jface.viewers.StructuredViewer$2.run
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.core.internal.runtime.InternalPlatform.run
(org.eclipse.core.runtime_3.1.2.jar.so)
   at org.eclipse.core.runtime.Platform.run (org.eclipse.core.runtime_3.1.2.jar.so)
   at org.eclipse.ui.internal.JFaceUtil$1.run
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.jface.util.SafeRunnable.run (org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.viewers.StructuredViewer.fireOpen
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.viewers.StructuredViewer.handleOpen
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.viewers.StructuredViewer$6.handleOpen
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.util.OpenStrategy.fireOpenEvent
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.util.OpenStrategy.access$2 (org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.jface.util.OpenStrategy$1.handleEvent
(org.eclipse.jface_3.1.1.jar.so)
   at org.eclipse.swt.widgets.EventTable.sendEvent
(org.eclipse.swt.gtk.linux.x86_64_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Widget.sendEvent
(org.eclipse.swt.gtk.linux.x86_64_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.runDeferredEvents
(org.eclipse.swt.gtk.linux.x86_64_3.1.1.jar.so)
   at org.eclipse.swt.widgets.Display.readAndDispatch
(org.eclipse.swt.gtk.linux.x86_64_3.1.1.jar.so)
   at org.eclipse.ui.internal.Workbench.runEventLoop
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.Workbench.runUI
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.PlatformUI.createAndRunWorkbench
(org.eclipse.ui.workbench_3.1.2.jar.so)
   at org.eclipse.ui.internal.ide.IDEApplication.run
(org.eclipse.ui.ide_3.1.1.jar.so)
   at org.eclipse.core.internal.runtime.PlatformActivator$1.run
(org.eclipse.core.runtime_3.1.2.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run
(org.eclipse.osgi_3.1.2.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run
(org.eclipse.osgi_3.1.2.jar.so)
   at java.lang.reflect.Method.invoke (libgcj.so.7)
   at org.eclipse.core.launcher.Main.invokeFramework (startup.jar.so)
   at org.eclipse.core.launcher.Main.basicRun (startup.jar.so)
   at org.eclipse.core.launcher.Main.run (startup.jar.so)
   at org.eclipse.core.launcher.Main.main (startup.jar.so)

Expected results:
File should be created and saved

Additional info:
$ rpm -qa | grep gcj
libgcj-4.1.0-0.25
java-1.4.2-gcj-compat-1.4.2.0-40jpp_80rh
libgcj-devel-4.1.0-0.25
libgcj-4.1.0-0.25
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_80rh
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp_80rh
Comment 1 Andrew Overholt 2006-02-20 11:45:49 EST
I can't duplicate this on i386.  I will try to find an x86_64 system on which to
test.
Comment 2 Dawid Zamirski 2006-02-21 20:31:44 EST
Solved. I did a fresh installation of FC5T3 today followed by yum update and it
seems to be working ok now. I must have had some packages installed incorrectly
in my previous install.
Comment 3 Andrew Overholt 2006-02-22 10:45:02 EST
(In reply to comment #2)
> Solved. I did a fresh installation of FC5T3 today followed by yum update and it
> seems to be working ok now.

Cool.  Closing.

Note You need to log in before you can comment on or make changes to this bug.