Bug 1815128 - Degree sign and other symbols not showing correctly in R graphics on Fedora 31/32
Summary: Degree sign and other symbols not showing correctly in R graphics on Fedora 3...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R
Version: 31
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-19 14:44 UTC by Giorgio Comai
Modified: 2020-05-13 07:37 UTC (History)
15 users (show)

Fixed In Version: R-3.6.3-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 07:37:11 UTC
Type: Bug


Attachments (Terms of Use)
Exampe of wrong output (5.04 KB, image/png)
2020-03-19 14:44 UTC, Giorgio Comai
no flags Details

Description Giorgio Comai 2020-03-19 14:44:32 UTC
Created attachment 1671482 [details]
Exampe of wrong output

Description of problem:

When using libraries that refer to the degree sign in graphics - ° - in the R programming language e.g. to express coordinates an unrelated symbol appears.

Version-Release number of selected component (if applicable):


How reproducible:
Reproducible.

Steps to Reproduce:
1. install R-core
2. start R
3. run e.g. "plot.new(); text(0.5,0.5, bquote(120*degree*N), cex=5)"

Actual results:
garbled sign instead of ° sign

Expected results:
actual ° sign


Additional info:
Issue on SO with more details:
https://stackoverflow.com/questions/60656445/how-to-fix-degree-symbol-not-showing-correctly-in-r-on-linux-fedora-31

Tested with a fresh install of Fedora 32 beta, with the same result. This was not an issue with Fedora 30 and earlier.

I am unsure if this is an issue with the symbol fonts themselves - apparently "urw-base35-standard-symbols-ps-fonts" - or with the R libraries that use them, e.g. "R-Cairo"

More details on fonts in R inthis context, e.g. here: https://www.rdocumentation.org/packages/grDevices/versions/3.6.2/topics/x11

Comment 1 Giorgio Comai 2020-03-20 08:43:56 UTC
Move to 'pango', as this seems to be a regression. 

The issue does not appear if pango is downgraded w.g. with - sudo dnf downgrade --releasever 30 pango-1.43.0-4.fc30.x86_64

The reason may be as detailed in this SO answer:

> pango was upgraded to 1.44, which affects bitmap fonts like the default R-Studio font due to the switch from Freetype to HarfBuzz
https://stackoverflow.com/a/60733863/4124601

Either way, if this prevents all R users on Fedora from having symbols in default graphics, it would be great to have it solved at the package level.

Comment 2 Peng Wu 2020-03-23 04:20:45 UTC
In pango 1.44, pango switch to use harfbuzz and dropped Adobe Type 1 font support.

We suggest to use makeotf from Adobe Font Development Kit for OpenType
to convert the PostScript fonts to OpenType fonts.
URL: https://bugzilla.redhat.com/show_bug.cgi?id=1809918

Before that, maybe you could try to use makeotf to convert the fonts,
and install the fonts into ~/.local/share/fonts/ .
Maybe the above conversion can make the Degree sign work again.

Comment 3 Iñaki Ucar 2020-03-29 19:37:03 UTC
This should be moved to "R" instead of "pango". See https://stat.ethz.ch/pipermail/r-devel/2020-March/079186.html for a detailed explanation on what's the issue. Paul Murrell is already working on a fix for R: https://stat.ethz.ch/pipermail/r-devel/2020-March/079230.html

Comment 4 Iñaki Ucar 2020-03-29 20:02:21 UTC
Upstream issue: https://bugs.r-project.org/bugzilla/show_bug.cgi?id=17748

Comment 5 Fedora Update System 2020-05-04 20:22:15 UTC
FEDORA-2020-4463b97145 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4463b97145

Comment 6 Fedora Update System 2020-05-05 04:40:59 UTC
FEDORA-2020-4463b97145 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4463b97145`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4463b97145

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-05-13 07:37:11 UTC
FEDORA-2020-4463b97145 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.