Bug 1815144 - glibmm24 2.64.1 breaks building of ardour5
Summary: glibmm24 2.64.1 breaks building of ardour5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glibmm24
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-19 15:31 UTC by Guido Aulisi
Modified: 2020-03-24 20:40 UTC (History)
4 users (show)

Fixed In Version: glibmm24-2.64.1-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 20:40:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Guido Aulisi 2020-03-19 15:31:23 UTC
Description of problem:
Updating of glibmm to 2.64.1 broke building of ardour5

Version-Release number of selected component (if applicable):
2.64.0-1.fc33

How reproducible:
Always

Steps to Reproduce:
1. Build current ardour5 srpm in Fedora rawhide

Actual results:
Build fails because build_filename has been converted to a template.
See [0].

While patching ardour to fix this problem I got another fail in

In file included from ../libs/pbd/basename.cc:21:
/usr/include/glibmm-2.4/glibmm/miscutils.h: In function ‘std::string Glib::build_filename(const Strings& ...)’:
/usr/include/glibmm-2.4/glibmm/miscutils.h:531:16: error: ‘convert_return_gchar_ptr_to_stdstring’ is not a member of ‘Glib’
  531 |   return Glib::convert_return_gchar_ptr_to_stdstring(
      |                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Expected results:
ardour5 builds fine

Additional info:
The first error could be a wrong use of vectors, but the second one seems internal to glibmm.

[0]: https://koji.fedoraproject.org/koji/taskinfo?taskID=42614701

Comment 1 Kalev Lember 2020-03-19 15:54:34 UTC
Thanks, I filed it upstream at https://gitlab.gnome.org/GNOME/glibmm/issues/71

Comment 2 Fedora Update System 2020-03-20 21:25:42 UTC
FEDORA-2020-da3b13157f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-da3b13157f

Comment 3 Fedora Update System 2020-03-21 01:44:14 UTC
glibmm24-2.64.1-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-da3b13157f

Comment 4 Guido Aulisi 2020-03-23 17:18:29 UTC
With glibmm24-2.64.1-2.fc33 ardour5 builds fine.

Comment 5 Fedora Update System 2020-03-24 20:40:03 UTC
FEDORA-2020-da3b13157f has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.