Bug 181522 - gnome-power-manager crashes because of selinux
gnome-power-manager crashes because of selinux
Status: CLOSED DUPLICATE of bug 181489
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 15:12 EST by Rowan Kerr
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 17:21:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rowan Kerr 2006-02-14 15:12:02 EST
Description of problem:
gnome-power-manager crashes on startup (logging in to Gnome session). SELinux
policy seems to be preventing it from interfacing with DBus.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.13.5.0 20060207-2
dbus-x11-0.60-7.2
libselinux-1.29.7-1.2
selinux-policy-2.2.14-2

How reproducible:
Enable SELinux in installer (fc5t2), log in to Gnome.

Steps to Reproduce:
1. Install FC5T2 with SELinux enabled
2. Upgrade to Rawhide
3. Log in to Gnome
  
Actual results:
Error message indicating gnome-power-manager has crashed.

Expected results:
Power manager applet starts and runs in Gnome panel.

Additional info:
This has been a persistent problem from a clean install of FC5T2 all the way up
to the most recent Rawhide updates.

When trying to start gnome-power-manager from a terminal, this message prints out:
** (gnome-power-manager:2347):WARNING **: main: an SELinux policy prevents this
sender from sending this message... (rejected message had interface
"org.freedesktop.DBus" member "Hello" error name "(unset") destination
"org.freedeesktop.DBus") 

And in /var/log/audit/audit.log, this message:
type=USER_AVC msg=audit(1139940939.476:4123): user pid=1528 uid=81
auid=4294967295 msg='avc:  denied  { send_msg } for msgtype=method_call
interface=org.freedesktop.DBus member=Hello dest=org.freedesktop.DBus spid=2994
scontext=user_u:system_r:unconfined_t tcontext=system_u:system_r:initrc_t
tclass=dbus : exe="?" (sauid=81, hostname=?, addr=?, terminal=?)'

I have never used SELinux before. I simply left it enabled in the FC5T2
installer and have not changed any of the configuration since.
Comment 1 Rowan Kerr 2006-02-14 16:56:54 EST
Switching SELinux to Permissive mode allows gnome-power-manager (and
NetworkManager applet also) to load correctly.
Comment 2 John (J5) Palmieri 2006-02-14 17:21:36 EST
Update tomorrow and reboot.

*** This bug has been marked as a duplicate of 181489 ***

Note You need to log in before you can comment on or make changes to this bug.