Bug 181524 - RFE: Make searching for duplicates search closed bugs as well
RFE: Make searching for duplicates search closed bugs as well
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Jeff Fearn
Kevin Baker
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-14 15:12 EST by Toshio Kuratomi
Modified: 2014-12-01 18:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 12:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Kuratomi 2006-02-14 15:12:48 EST
Description of problem:
When searching for duplicate bugs, searching for closed bugs as well as open
bugs will increase the chances of catching bugs that have been closed in a later
 release of the package/distribution.  Otherwise, many duplicate filings will
occur where the end-user submits a bug report, not knowing the bug has already
been fixed in Rawhide.

Additional Thoughts:
This would be especially useful when an end-user is attempting to file a new bug
and they are checking for duplicate bugs before filing.  One possibility that
stems from this is to have the query that checks for duplicates when submitting
new bugs show closed bugs by default while the normal query interface defaults
to open only.

One consideration is that _all_ bugs on a Component are not going to be relevant
to determining if a bug is a duplicate.  One way we'd want to limit this is by
Product in order to separate Fedora from RHEL.  Ideally, we'd know the user's
Product-Version and query for open or closed bugs on that Product-Version  or
later.  (So if I have a bug in autoconf on FC3, the query would look for
autoconf & Fedora Core & Version = {3,4,devel}).
Comment 1 Orion Poplawski 2006-02-14 17:48:30 EST
Seconded.  I always search for bugs this way anymore via the advanced search
mechanism because so many bug are closed in rawhide before a current fix is
released.

Also, since dupes are "closed" they don't get searched by default, but sometimes
bug exhibit different characteristics or people phrase things differently. 
Searching dupes increases the chances that you'll find a match.
Comment 2 Toshio Kuratomi 2006-02-14 20:45:00 EST
My idea for eliminating bugs before FC(n) is slightly flawed.  CLOSED bugs for
FC < n should be ignored.  OPEN bugs should be found no matter which Version of
the Product they occured on.
Comment 3 Bill Crawford 2006-03-11 17:09:55 EST
Another point.

Bugs that get refiled from one component to another (e.g. something got filed as
a firefox bug and was moved to something else because it turned out to be a bug
in one of the underlying libraries) should show up if someone searches the
original component.

Perhaps this could be limited to "and if some other entered keyword matches" ...

Also, it would help if existing bugs could perhaps be tagged as interesting to
searchers on other components, e.g. the recent python-sqlite bug (you know,
*that* one) should show in searches for bugs against yum, and/or sqlite3 too.

Thirdly, it really would be nice if some hierarchy could be added. Sometimes it
would be great if one could file a bug marked against "something in the desktop
stack" rather than trying to identify exactly which component is at fault. This
is a bit of a vague one, I know, and highlights one of the irreducible
complexities of "bug tracking" but "someone" should do something ;)
Comment 4 Bill Crawford 2006-03-11 17:10:29 EST
(forgot to add myself to Cc list, sorry)
Comment 5 Bill Crawford 2006-03-11 17:11:12 EST
Another one: create a tracker for bugzilla RFEs. Unless there is one and I
missed it.
Comment 6 David Lawrence 2010-01-15 12:33:39 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 7 David Lawrence 2010-08-25 17:44:17 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 9 Jeff Fearn 2012-05-30 00:48:46 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 10 Toshio Ernie Kuratomi 2012-05-30 12:21:12 EDT
The flow of opening a new bug has changed.  Bugzilla now has javascript that displays several potential duplicates.  Since this no longer requires the user to do something, it's less visible to them if they're filing unfound duplicates.  Someone could reopen this if they find, as a maintainer, they are closing a bunch of dupes and can figure out a new way to integrate that into the UI.

There's also separate issue in the comments of this bug.  I'll let those commenters open new, separate bugs.

Note You need to log in before you can comment on or make changes to this bug.