Bug 1815433 - OCPRHV-120: [ovirt] Installer lets you choose cluster in uninitialized data center
Summary: OCPRHV-120: [ovirt] Installer lets you choose cluster in uninitialized data c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Linux
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Douglas Schilling Landgraf
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-20 09:26 UTC by Jan Zmeskal
Modified: 2020-10-27 15:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:56:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:56:56 UTC

Description Jan Zmeskal 2020-03-20 09:26:16 UTC
Description of problem:
When running openshift-install for ovirt platform, at one point user is prompted to choose cluster to deploy OCP on. Among the selection, there's also cluster residing in uninitialized data center. When chosen, installer fails with error.

Version-Release number of the following components:
openshift-install-linux-4.4.0-0.nightly-2020-03-20-031454
rhvm-4.3.9.0-0.1.el7.noarch

How reproducible:
100 %

Steps to Reproduce:
1. Have an oVirt engine with the data centres - one of them in Up state, the other one in Uninitialized
2. Run openshift-install create install-config
3. Answer to the survey questions. When you come to question "Select the oVirt cluster", choose cluster in uninitialized DC

Actual results:
./openshift-install create install-config --dir=test-cluster
? SSH Public Key /root/.ssh/id_rsa.pub
? Platform ovirt
? Enter oVirt's api endpoint URL https://<engine_fqdn>/ovirt-engine/api
? Is the installed oVirt certificate trusted? No
? Enter ovirt-engine username admin@internal
? Enter password ******
? Select the oVirt cluster Default
FATAL failed to fetch Install Config: failed to fetch dependency of "Install Config": failed to fetch dependency of "Base Domain": failed to generate asset "Platform": please provide options to select from

Expected results:
Clusters in non-functioning DCs shouldn't be offered or, if that cannot be achieved, user should get a clear message why the installer failed.

Comment 3 Jan Zmeskal 2020-06-11 13:11:02 UTC
Verified with: openshift-install-linux-4.6.0-0.nightly-2020-06-11-041445

The cluster in uninitialized data center is no longer offered by the CLI survey.

Comment 6 errata-xmlrpc 2020-10-27 15:56:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.