Bug 1815434 - [samba-disperse] unable to create files in samba share with non-root user for distribute disperse volume
Summary: [samba-disperse] unable to create files in samba share with non-root user for...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: md-cache
Version: rhgs-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: RHGS 3.5.z Batch Update 3
Assignee: Xavi Hernandez
QA Contact: Aditya Ramteke
URL:
Whiteboard:
: 1815432 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-20 09:26 UTC by Vivek Das
Modified: 2020-12-17 04:51 UTC (History)
8 users (show)

Fixed In Version: glusterfs-6.0-38
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-17 04:51:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github gluster glusterfs issues 1140 0 None closed getfattr returns ENOATTR for system.posix_acl_access on disperse type volumes 2020-12-13 15:19:51 UTC
Red Hat Product Errata RHBA-2020:5603 0 None None None 2020-12-17 04:51:41 UTC

Description Vivek Das 2020-03-20 09:26:59 UTC
Description of problem:
Creation of directories failed in samba share when mounted using non-root user
for distribute disperse volume.

Version-Release number of selected component (if applicable):
samba-4.11.6-104.el7rhgs.x86_64
glusterfs-6.0-30.1.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create distribute-disperse volume
2. Do a cifs mount using the volume with non-root user
3. Try to create a directory in the share

Actual results:
create fails

Expected results:
create should succeed

Additional info:
error message:
mkdir: cannot create directory ‘/mnt/dist-cifs/vicky-fuse/test-non’: Permission denied

[2020-03-20 06:45:58.989471] E [MSGID: 122075] [ec-code.c:425:ec_code_space_create] 0-vicky-disperse-1: Unable to create a temporary file for the ec dynamic code [Permission denied]
[2020-03-20 06:45:58.990498] I [MSGID: 122068] [ec-code.c:1052:ec_code_detect] 0-vicky-disperse-0: Using 'sse' CPU extensions
[2020-03-20 06:45:58.990554] E [MSGID: 122075] [ec-code.c:425:ec_code_space_create] 0-vicky-disperse-0: Unable to create a temporary file for the ec dynamic code [Permission denied]


Note: This issue is not seen in other volume type.
This is not a regression.


Volume Name: vicky
Type: Distributed-Disperse
Volume ID: 01edb3a0-df04-435e-97b5-106c15ea0b63
Status: Started
Snapshot Count: 0
Number of Bricks: 2 x (2 + 1) = 6
Transport-type: tcp
Bricks:
Brick1: 10.70.43.181:/bricks/brick1/vicky
Brick2: 10.70.43.185:/bricks/brick1/vicky
Brick3: 10.70.43.189:/bricks/brick1/vicky
Brick4: 10.70.43.178:/bricks/brick2/vicky
Brick5: 10.70.43.181:/bricks/brick2/vicky
Brick6: 10.70.43.185:/bricks/brick2/vicky
Options Reconfigured:
user.cifs: enable
performance.parallel-readdir: on
performance.readdir-ahead: on
performance.nl-cache-timeout: 600
performance.nl-cache: on
network.inode-lru-limit: 200000
performance.md-cache-timeout: 600
performance.cache-invalidation: on
performance.stat-prefetch: on
performance.cache-samba-metadata: on
features.cache-invalidation-timeout: 600
features.cache-invalidation: on
transport.address-family: inet
storage.fips-mode-rchecksum: on
nfs.disable: on

Comment 2 Vivek Das 2020-03-20 10:19:46 UTC
*** Bug 1815432 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2020-12-17 04:51:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (glusterfs bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5603


Note You need to log in before you can comment on or make changes to this bug.