Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1815437 - [abrt] pulseaudio: sink_set_port_ucm_cb(): pulseaudio killed by SIGABRT [NEEDINFO]
Summary: [abrt] pulseaudio: sink_set_port_ucm_cb(): pulseaudio killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:932157de3fcfd8c6949170c189d...
: 1815660 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-20 09:35 UTC by Hugo Leonardo R. D. Lopes
Modified: 2020-03-24 20:40 UTC (History)
4 users (show)

Fixed In Version: pulseaudio-13.99.1-2.fc31 pulseaudio-13.99.1-2.fc32
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 01:48:53 UTC
Type: ---
hlopes: needinfo? (extras-qa)


Attachments (Terms of Use)
File: backtrace (28.28 KB, text/plain)
2020-03-20 09:35 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: core_backtrace (9.61 KB, text/plain)
2020-03-20 09:35 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: cpuinfo (2.04 KB, text/plain)
2020-03-20 09:35 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: dso_list (7.58 KB, text/plain)
2020-03-20 09:35 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: environ (535 bytes, text/plain)
2020-03-20 09:35 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: limits (1.29 KB, text/plain)
2020-03-20 09:36 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: maps (44.00 KB, text/plain)
2020-03-20 09:36 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: mountinfo (2.47 KB, text/plain)
2020-03-20 09:36 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: open_fds (3.54 KB, text/plain)
2020-03-20 09:36 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: proc_pid_status (1.31 KB, text/plain)
2020-03-20 09:36 UTC, Hugo Leonardo R. D. Lopes
no flags Details
File: var_log_messages (1.03 KB, text/plain)
2020-03-20 09:36 UTC, Hugo Leonardo R. D. Lopes
no flags Details

Description Hugo Leonardo R. D. Lopes 2020-03-20 09:35:30 UTC
Description of problem:
After kernel update and restart, audio and microfone don't work. Streaming of video and audio in internet dont work, in youtube.com, radioparadise.com and oters websites.

Version-Release number of selected component:
pulseaudio-13.99.1-1.fc31

Additional info:
reporter:       libreport-2.12.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/pulseaudio.service
cmdline:        /usr/bin/pulseaudio --daemonize=no
crash_function: sink_set_port_ucm_cb
executable:     /usr/bin/pulseaudio
journald_cursor: s=4205282a5b374ddeaf405afa549ca60b;i=1c6c;b=3f2619a37c6945b8bd2cce4154b91207;m=7ca5d6ef;t=5a13f53adbfb5;x=50d2d5d6adfcabc3
kernel:         5.5.9-200.fc31.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
xsession_errors:

Comment 1 Hugo Leonardo R. D. Lopes 2020-03-20 09:35:35 UTC
Created attachment 1671810 [details]
File: backtrace

Comment 2 Hugo Leonardo R. D. Lopes 2020-03-20 09:35:37 UTC
Created attachment 1671811 [details]
File: core_backtrace

Comment 3 Hugo Leonardo R. D. Lopes 2020-03-20 09:35:39 UTC
Created attachment 1671812 [details]
File: cpuinfo

Comment 4 Hugo Leonardo R. D. Lopes 2020-03-20 09:35:47 UTC
Created attachment 1671813 [details]
File: dso_list

Comment 5 Hugo Leonardo R. D. Lopes 2020-03-20 09:35:56 UTC
Created attachment 1671814 [details]
File: environ

Comment 6 Hugo Leonardo R. D. Lopes 2020-03-20 09:36:02 UTC
Created attachment 1671815 [details]
File: limits

Comment 7 Hugo Leonardo R. D. Lopes 2020-03-20 09:36:10 UTC
Created attachment 1671816 [details]
File: maps

Comment 8 Hugo Leonardo R. D. Lopes 2020-03-20 09:36:13 UTC
Created attachment 1671817 [details]
File: mountinfo

Comment 9 Hugo Leonardo R. D. Lopes 2020-03-20 09:36:19 UTC
Created attachment 1671818 [details]
File: open_fds

Comment 10 Hugo Leonardo R. D. Lopes 2020-03-20 09:36:22 UTC
Created attachment 1671819 [details]
File: proc_pid_status

Comment 11 Hugo Leonardo R. D. Lopes 2020-03-20 09:36:24 UTC
Created attachment 1671820 [details]
File: var_log_messages

Comment 12 Fedora Update System 2020-03-21 01:29:34 UTC
pulseaudio-13.99.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-84f3962ea9

Comment 13 Wim Taymans 2020-03-23 08:41:34 UTC
*** Bug 1815660 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2020-03-23 09:22:30 UTC
FEDORA-2020-6808aded96 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6808aded96

Comment 15 Hugo Leonardo R. D. Lopes 2020-03-23 19:33:41 UTC
I start solving my problem.
I have Gnome, LXDE and XFCE4 installed.
I decided to be more radical and I will be the most explained here, so that the main team tries to do the same procedures and try to arrive at a more credible solution. In the meantime I will keep trying.

# dnf remove pulseaudio * alsa * >> test.txt
# (y or n?) n
#dnf remov pulseaudio * alsa * -y
#shutdown -r now
#dnf install pavucontrol
#dnf install pulseaudio alsa
#shutdown -r now
#dnf install google-chrome-stable

After that, bingo!
The video on youtube.com started playing, a problem that we didn't even start. However, the video started to start in an unconventional way, that is, 3 or 4 seconds faster and without audio.

I accessed the website of my pay-TV (nos.pt), and it was as I mentioned at the beginning, the video was static, just like a photo and does not come out audio, as on youtube.com. After doing these procedures above, the video started, but with a different problem from youtube.com, that is, there was no audio, as mentioned, but the video streaming was 1 second static and then passed 3 or 4 seconds faster.

 As I always did and most users, I used easylife to install several video and audio codecs. this time I didn't! I will try to install some specific video codecs like ffmpeg among others, one at a time, until I try to solve it once and for all.

My perception of this:

There may be some line or code in the pulseaudio that working in association with a video or audio codec may be causing this problem.

I would like to ask dearly on behalf of all users that the team performs the same procedure as I did. We try to watch a video on youtube.com and other online video, stream and radio websites.

I count on your experience, help and commitment, so that this problem, like many other difficulties that we have been through together, can be solved.

Sincerely,

Hugo Leonardo R. D. Lopes (wkgames) - "Hugo de Recife"

Comment 16 Fedora Update System 2020-03-24 01:48:53 UTC
FEDORA-2020-84f3962ea9 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-03-24 01:51:54 UTC
FEDORA-2020-6808aded96 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-6808aded96`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6808aded96

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2020-03-24 20:40:05 UTC
FEDORA-2020-6808aded96 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.