Bug 1815544 - libreport crashes when trying to report a crash on X11 (BadAlloc)
Summary: libreport crashes when trying to report a crash on X11 (BadAlloc)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: ekulik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-20 14:26 UTC by Kamil Páral
Modified: 2022-01-26 15:59 UTC (History)
10 users (show)

Fixed In Version: libreport-2.12.0-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-25 01:56:19 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
bug demonstration video (2.81 MB, video/webm)
2020-03-20 14:27 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2020-03-20 14:26:40 UTC
Description of problem:
When I want to report a crash from abrt on Wayland, it works fine. But when I try it from X11, libreport crashes. It crashes after it tells me that remote retracing didn't work. Immediately after I hit OK, it crashes.

Version-Release number of selected component (if applicable):
abrt-2.14.0-2.fc32.x86_64
gnome-abrt-1.3.1-1.fc32.x86_64
gtk3-3.24.14-1.fc32.i686
gtk3-3.24.14-1.fc32.x86_64
libreport-2.12.0-2.fc32.x86_64

How reproducible:
always

Steps to Reproduce:
1. log in under X11
2. run gnome-calculator
3. killall -ABRT gnome-calculator
4. click on the notification that an app has crashed, or start ABRT manually
5. report the problem
6. say Yes to uploading a core dump
7. wait until it says remote retracing has failed (because retrace server is still broken)
8. once you hit OK, libreport crashes

Comment 1 Kamil Páral 2020-03-20 14:27:26 UTC
Created attachment 1671931 [details]
bug demonstration video

Comment 2 Kamil Páral 2020-03-20 14:28:54 UTC
Journal says:
Mar 20 15:21:58 phoenix abrt-applet[66111]: (org.freedesktop.GnomeAbrt:66112): Gdk-ERROR **: 15:21:58.255: The program 'org.freedesktop.GnomeAbrt' received an X Window System error.
Mar 20 15:21:58 phoenix abrt-applet[66111]: This probably reflects a bug in the program.
Mar 20 15:21:58 phoenix abrt-applet[66111]: The error was 'BadAlloc (insufficient resources for operation)'.
Mar 20 15:21:58 phoenix abrt-applet[66111]:   (Details: serial 308136 error_code 11 request_code 130 (MIT-SHM) minor_code 5)
Mar 20 15:21:58 phoenix abrt-applet[66111]:   (Note to programmers: normally, X errors are reported asynchronously;
Mar 20 15:21:58 phoenix abrt-applet[66111]:    that is, you will receive the error a while after causing it.
Mar 20 15:21:58 phoenix abrt-applet[66111]:    To debug your program, run it with the GDK_SYNCHRONIZE environment
Mar 20 15:21:58 phoenix abrt-applet[66111]:    variable to change this behavior. You can then get a meaningful
Mar 20 15:21:58 phoenix abrt-applet[66111]:    backtrace from your debugger if you break on the gdk_x_error() function.)
Mar 20 15:21:58 phoenix kernel: traps: report-gtk[66112] trap int3 ip:7f363f4b474b sp:7ffc0bfd3500 error:0 in libglib-2.0.so.0.6400.1[7f363f475000+86000]
Mar 20 15:21:58 phoenix systemd[1]: Started Process Core Dump (PID 66504/UID 0).
Mar 20 15:22:01 phoenix systemd-coredump[66505]: Core file was truncated to 2147483648 bytes.
Mar 20 15:22:01 phoenix abrt-dump-journal-core[1219]: Failed to obtain all required information from journald
Mar 20 15:22:01 phoenix systemd-coredump[66505]: Process 66112 (report-gtk) of user 1000 dumped core.
                                                 
                                                 Stack trace of thread 66112:
                                                 #0  0x00007f363f4b474b n/a (n/a + 0x0)
Mar 20 15:22:01 phoenix systemd[1]: systemd-coredump: Succeeded.
Mar 20 15:22:01 phoenix systemd[1]: systemd-coredump: Consumed 3.268s CPU time.
Mar 20 15:22:03 phoenix abrtd[1174]: Size of '/var/spool/abrt' >= 10000 MB (MaxCrashReportsSize), deleting old directory 'ccpp-2020-03-20-15:16:05.511605-65851'
Mar 20 15:22:03 phoenix abrt-server[66522]: Error: No segments found in coredump './coredump'
Mar 20 15:22:04 phoenix abrt-server[66522]: Can't open file 'core_backtrace' for reading: No such file or directory
Mar 20 15:22:04 phoenix abrt-notification[66563]: Process 66112 (report-gtk) crashed in ??()

Comment 3 Kamil Páral 2020-03-20 14:30:07 UTC
The libreport crash can't be processed by libreport, because it says:

--- Running report_uReport ---
Error: No segments found in coredump './coredump'
('report_uReport' exited with 1)

Comment 4 Kamil Páral 2020-03-20 14:36:27 UTC
I tried to get some interesting information from coredumpctl, but the coredump is truncated (not sure why and what it means), and no interesting info seems to be available:

$ coredumpctl debug 66112
           PID: 66112 (report-gtk)
           UID: 1000 (kparal)
           GID: 1000 (kparal)
        Signal: 5 (TRAP)
     Timestamp: Fri 2020-03-20 15:21:58 CET (12min ago)
  Command Line: report-gtk -- /var/spool/abrt/ccpp-2020-03-20-15:16:05.511605-65851
    Executable: /usr/bin/report-gtk
 Control Group: /user.slice/user-1000.slice/user/dbus\x2d:1.2\x2dorg.freedesktop.problems.applet.slice/dbus-:1.2-org.freedesktop.problems.applet
          Unit: user
     User Unit: dbus-:1.2-org.freedesktop.problems.applet
         Slice: user-1000.slice
     Owner UID: 1000 (kparal)
       Boot ID: 2eb9a5bddb92441583c12c21f0a8c32a
    Machine ID: 7021cad0a42a400b8cf908ca7ced42c6
      Hostname: phoenix
       Storage: /var/lib/systemd/coredump/core.report-gtk.1000.2eb9a5bddb92441583c12c21f0a8c32a.66112.1584714118000000000000.lz4 (truncated)
       Message: Process 66112 (report-gtk) of user 1000 dumped core.
                
                Stack trace of thread 66112:
                #0  0x00007f363f4b474b n/a (n/a + 0x0)

GNU gdb (GDB) Fedora 9.1-3.fc32
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/report-gtk...
Reading symbols from /usr/lib/debug/usr/bin/report-gtk-2.12.0-2.fc32.x86_64.debug...
BFD: warning: /var/tmp/coredump-2T7PU0 is truncated: expected core file size >= 17231347712, found: 2147483648
[New LWP 66112]
[New LWP 66113]
[New LWP 66114]
Cannot access memory at address 0x7f36400e7048
Cannot access memory at address 0x7f36400e7040
Failed to read a valid object file image from memory.
Core was generated by `report-gtk -- /var/spool/abrt/ccpp-2020-03-20-15:16:05.511605-65851'.
Program terminated with signal SIGTRAP, Trace/breakpoint trap.
#0  0x00007f363f4b474b in ?? ()
[Current thread is 1 (LWP 66112)]
(gdb) thread apply all backtrace

Thread 3 (LWP 66114):
#0  0x00007f363f3489cf in ?? ()
Backtrace stopped: Cannot access memory at address 0x7f362f883aa0

Thread 2 (LWP 66113):
#0  0x00007f363f3489cf in ?? ()
Backtrace stopped: Cannot access memory at address 0x7f3630084ab0

Thread 1 (LWP 66112):
#0  0x00007f363f4b474b in ?? ()
Backtrace stopped: Cannot access memory at address 0x7ffc0bfd3500
(gdb)

Comment 5 Kamil Páral 2020-03-20 14:37:35 UTC
Proposing as a F32FinalBlocker. The basic functionality of the problem reporter (i.e. reporting problems) is broken. On X11.

Comment 6 ekulik 2020-03-20 14:53:20 UTC
Confirming.

Comment 7 ekulik 2020-03-20 15:08:46 UTC
(In reply to Kamil Páral from comment #5)
> Proposing as a F32FinalBlocker. The basic functionality of the problem
> reporter (i.e. reporting problems) is broken. On X11.

That’s a bit of an overstatement. It’s really only for certain core dumps (coreutils is fine and I replicated this with nautilus and it was pulling in hundreds of MiBs of debuginfo packages, so maybe retrace-server is flooding us with data and we try to write it all at once and things happen, but that’s just conjecture so far) and I get the feeling it’s the same cause as in https://bugzilla.redhat.com/show_bug.cgi?id=1814046.

Comment 8 ekulik 2020-03-20 15:25:37 UTC
Actually, it works fine for me when running from git master. Peculiar, indeed.

Comment 9 ekulik 2020-03-20 15:34:48 UTC
Oh! It worked, because I had the log scrolled window collapsed. The plot thickens.

Comment 10 ekulik 2020-03-20 15:48:06 UTC
Yeah, allocating a 62830x4530 buffer will do it.

#0  gdk_x_error (xdisplay=0x470400, error=0x7fffffffb280) at gdkmain-x11.c:271
#1  0x00007ffff654f5cb in _XError (dpy=dpy@entry=0x470400, rep=rep@entry=0x8dffa0) at XlibInt.c:1491
#2  0x00007ffff654c337 in handle_error (dpy=0x470400, err=0x8dffa0, in_XReply=<optimized out>) at xcb_io.c:199
#3  0x00007ffff654c3d5 in handle_response (dpy=dpy@entry=0x470400, response=0x8dffa0, in_XReply=in_XReply@entry=1) at xcb_io.c:324
#4  0x00007ffff654d35d in _XReply (dpy=dpy@entry=0x470400, rep=rep@entry=0x7fffffffb440, extra=extra@entry=0, discard=discard@entry=1) at xcb_io.c:634
#5  0x00007ffff6548b8f in XSync (dpy=0x470400, discard=discard@entry=0) at Sync.c:44
#6  0x00007ffff6548c2f in _XSyncFunction (dpy=<optimized out>) at Synchro.c:35
#7  0x00007ffff654ff83 in _XPrivSyncFunction (dpy=0x470400) at XlibInt.c:244
#8  0x00007ffff60573e6 in XShmCreatePixmap () at /lib64/libXext.so.6
#9  0x00007ffff735ea60 in _cairo_xlib_shm_surface_create (other=other@entry=0x9fc400, format=PIXMAN_x8r8g8b8, width=width@entry=62830, height=height@entry=4530, will_sync=will_sync@entry=0, create_pixmap=4096) at cairo-xlib-surface-shm.c:843
#10 0x00007ffff735f3a8 in _cairo_xlib_surface_create_shm (height=4530, width=62830, format=<optimized out>, other=0x9fc400) at cairo-xlib-surface-shm.c:1156
#11 _cairo_xlib_surface_create_similar_shm (other=0x9fc400, format=CAIRO_FORMAT_RGB24, width=62830, height=4530) at cairo-xlib-surface-shm.c:1181
#12 0x00007ffff732ff9b in INT_cairo_surface_create_similar_image (other=<optimized out>, format=CAIRO_FORMAT_RGB24, width=62830, height=4530) at cairo-surface.c:595
#13 0x00007ffff7330187 in cairo_surface_create_similar (other=0x9fc400, content=CAIRO_CONTENT_COLOR, width=62830, height=4530) at cairo-surface.c:518
#14 0x00007ffff75ae9c9 in gdk_window_create_similar_surface (window=window@entry=0x94cc00 [GdkX11Window], content=content@entry=CAIRO_CONTENT_COLOR, width=62830, height=4530) at gdkwindow.c:10187
#15 0x00007ffff79124be in _gtk_pixel_cache_create_surface_if_needed (canvas_rect=0x7fffffffb910, view_rect=0x7fffffffb900, window=0x94cc00 [GdkX11Window], cache=0x86c8e0) at gtkpixelcache.c:236
#16 _gtk_pixel_cache_draw (cache=0x86c8e0, cr=0x981160, window=0x94cc00 [GdkX11Window], view_rect=0x7fffffffb900, canvas_rect=0x7fffffffb910, draw=0x7ffff79ac240 <draw_text>, user_data=0x5a6360) at gtkpixelcache.c:445
#17 0x00007ffff79b2e24 in gtk_text_view_draw (widget=0x5a6360 [GtkTextView], cr=0x981160) at gtktextview.c:6042
#18 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x5a6360 [GtkTextView], cr=cr@entry=0x981160, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#19 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x86d280 [GtkViewport], child=0x5a6360 [GtkTextView], cr=cr@entry=0x981160) at gtkcontainer.c:3853
#20 0x00007ffff77e2b25 in gtk_container_draw (widget=0x86d280 [GtkViewport], cr=0x981160) at gtkcontainer.c:3673
#21 0x00007ffff79126fd in _gtk_pixel_cache_repaint (user_data=0x86d280, canvas_rect=0x7fffffffbc50, view_rect=0x7fffffffbc40, draw=0x7ffff7a064d0 <draw_bin>, window=0x94c720 [GdkX11Window], cache=0x86c5f0) at gtkpixelcache.c:358
#22 _gtk_pixel_cache_draw (cache=0x86c5f0, cr=0xa6f710, window=0x94c720 [GdkX11Window], view_rect=0x7fffffffbc40, canvas_rect=0x7fffffffbc50, draw=0x7ffff7a064d0 <draw_bin>, user_data=0x86d280) at gtkpixelcache.c:448
#23 0x00007ffff7a06699 in gtk_viewport_render (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>, data=0x0) at gtkviewport.c:357
#24 0x00007ffff77e7fb1 in gtk_css_custom_gadget_draw (gadget=<optimized out>, cr=<optimized out>, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkcsscustomgadget.c:159
#25 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=0x861700 [GtkCssCustomGadget], cr=cr@entry=0xa6f710) at gtkcssgadget.c:885
#26 0x00007ffff7a07491 in gtk_viewport_draw (widget=<optimized out>, cr=0xa6f710) at gtkviewport.c:946
#27 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x86d280 [GtkViewport], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#28 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x7cf750 [GtkScrolledWindow], child=0x86d280 [GtkViewport], cr=cr@entry=0xa6f710) at gtkcontainer.c:3853
#29 0x00007ffff77e2b25 in gtk_container_draw (widget=0x7cf750 [GtkScrolledWindow], cr=0xa6f710) at gtkcontainer.c:3673
#30 0x00007ffff79428cd in gtk_scrolled_window_render (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>, data=0x0) at gtkscrolledwindow.c:2103
#31 0x00007ffff77e7fb1 in gtk_css_custom_gadget_draw (gadget=<optimized out>, cr=<optimized out>, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkcsscustomgadget.c:159
#32 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=0x861080 [GtkCssCustomGadget], cr=0xa6f710) at gtkcssgadget.c:885
#33 0x00007ffff79407f5 in gtk_scrolled_window_draw (widget=<optimized out>, cr=<optimized out>) at gtkscrolledwindow.c:3030
#34 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x7cf750 [GtkScrolledWindow], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#35 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x82fef0 [GtkExpander], child=child@entry=0x7cf750 [GtkScrolledWindow], cr=cr@entry=0xa6f710) at gtkcontainer.c:3853
#36 0x00007ffff7796659 in gtk_box_gadget_draw (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkboxgadget.c:510
#37 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=0x861a40 [GtkBoxGadget], cr=0xa6f710) at gtkcssgadget.c:885
#38 0x00007ffff7839c65 in gtk_expander_draw (widget=<optimized out>, cr=<optimized out>) at gtkexpander.c:720
#39 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x82fef0 [GtkExpander], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#40 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x8426d0 [GtkBox], child=0x82fef0 [GtkExpander], cr=cr@entry=0xa6f710) at gtkcontainer.c:3853
#41 0x00007ffff77e2b25 in gtk_container_draw (widget=0x8426d0 [GtkBox], cr=cr@entry=0xa6f710) at gtkcontainer.c:3673
#42 0x00007ffff77925a8 in gtk_box_draw_contents (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>, unused=0x0) at gtkbox.c:453
#43 0x00007ffff77e7fb1 in gtk_css_custom_gadget_draw (gadget=<optimized out>, cr=<optimized out>, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkcsscustomgadget.c:159
#44 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=0x85e1a0 [GtkCssCustomGadget], cr=0xa6f710) at gtkcssgadget.c:885
#45 0x00007ffff7795005 in gtk_box_draw (widget=<optimized out>, cr=<optimized out>) at gtkbox.c:462
#46 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x8426d0 [GtkBox], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#47 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x716220 [GtkNotebook], child=0x8426d0 [GtkBox], cr=cr@entry=0xa6f710) at gtkcontainer.c:3853
#48 0x00007ffff78e128e in gtk_notebook_draw_stack (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>, unused=0x0) at gtknotebook.c:2544
#49 0x00007ffff77e7fb1 in gtk_css_custom_gadget_draw (gadget=<optimized out>, cr=<optimized out>, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkcsscustomgadget.c:159
#50 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=gadget@entry=0x566f70 [GtkCssCustomGadget], cr=cr@entry=0xa6f710) at gtkcssgadget.c:885
#51 0x00007ffff77966b3 in gtk_box_gadget_draw (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkboxgadget.c:512
#52 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=0x5fe390 [GtkBoxGadget], cr=cr@entry=0xa6f710) at gtkcssgadget.c:885
#53 0x00007ffff78e0434 in gtk_notebook_draw (widget=<optimized out>, cr=0xa6f710) at gtknotebook.c:2559
#54 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x716220 [GtkNotebook], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#55 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x735b50 [GtkBox], child=0x716220 [GtkNotebook], cr=cr@entry=0xa6f710) at gtkcontainer.c:3853
#56 0x00007ffff77e2b25 in gtk_container_draw (widget=0x735b50 [GtkBox], cr=cr@entry=0xa6f710) at gtkcontainer.c:3673
#57 0x00007ffff77925a8 in gtk_box_draw_contents (gadget=<optimized out>, cr=0xa6f710, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>, unused=0x0) at gtkbox.c:453
#58 0x00007ffff77e7fb1 in gtk_css_custom_gadget_draw (gadget=<optimized out>, cr=<optimized out>, x=<optimized out>, y=<optimized out>, width=<optimized out>, height=<optimized out>) at gtkcsscustomgadget.c:159
#59 0x00007ffff77edb17 in gtk_css_gadget_draw (gadget=0x718310 [GtkCssCustomGadget], cr=0xa6f710) at gtkcssgadget.c:885
#60 0x00007ffff7795005 in gtk_box_draw (widget=<optimized out>, cr=<optimized out>) at gtkbox.c:462
#61 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x735b50 [GtkBox], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#62 0x00007ffff77e2a18 in gtk_container_propagate_draw (container=container@entry=0x75e2c0 [GtkApplicationWindow], child=0x735b50 [GtkBox], cr=cr@entry=0xa6f710) at gtkcontainer.c:3853
#63 0x00007ffff77e2b25 in gtk_container_draw (widget=0x75e2c0 [GtkApplicationWindow], cr=0xa6f710) at gtkcontainer.c:3673
#64 0x00007ffff7a2456b in gtk_window_draw (widget=0x75e2c0 [GtkApplicationWindow], cr=0xa6f710) at gtkwindow.c:10486
#65 0x00007ffff7a15f44 in gtk_widget_draw_internal (widget=widget@entry=0x75e2c0 [GtkApplicationWindow], cr=cr@entry=0xa6f710, clip_to_size=clip_to_size@entry=1) at gtkwidget.c:7080
#66 0x00007ffff7a1f780 in gtk_widget_render (widget=widget@entry=0x75e2c0 [GtkApplicationWindow], window=0x99c7a0 [GdkX11Window], region=<optimized out>) at gtkwidget.c:17606
#67 0x00007ffff78bbd66 in gtk_main_do_event (event=0x7fffffffcc40) at gtkmain.c:1840
#68 gtk_main_do_event (event=<optimized out>) at gtkmain.c:1687
#69 0x00007ffff7595029 in _gdk_event_emit (event=event@entry=0x7fffffffcc40) at gdkevents.c:73
#70 0x00007ffff75a67d9 in _gdk_window_process_updates_recurse_helper (window=0x99c7a0 [GdkX11Window], expose_region=<optimized out>) at gdkwindow.c:3874
#71 0x00007ffff75a8401 in gdk_window_process_updates_internal (window=0x99c7a0 [GdkX11Window]) at gdkwindow.c:4020
#72 0x00007ffff75a85fd in gdk_window_process_updates_with_mode (window=<optimized out>, recurse_mode=<optimized out>) at gdkwindow.c:4215
#73 0x00007ffff705faf6 in _g_closure_invoke_va (closure=<optimized out>, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, n_params=<optimized out>, param_types=<optimized out>) at ../gobject/gclosure.c:873
#74 0x00007ffff7078813 in g_signal_emit_valist (instance=0x49d490, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fffffffcf40) at ../gobject/gsignal.c:3407
#75 0x00007ffff7078d93 in g_signal_emit (instance=instance@entry=0x49d490, signal_id=<optimized out>, detail=detail@entry=0) at ../gobject/gsignal.c:3554
#76 0x00007ffff759e5a3 in _gdk_frame_clock_emit_paint (frame_clock=frame_clock@entry=0x49d490 [GdkFrameClockIdle]) at gdkframeclock.c:643
#77 0x00007ffff759f29e in gdk_frame_clock_paint_idle (data=0x49d490) at gdkframeclockidle.c:450
#78 0x00007ffff758901d in gdk_threads_dispatch (data=data@entry=0x635780) at gdk.c:777
#79 0x00007ffff6f75311 in g_timeout_dispatch (source=source@entry=0xaeaf30, callback=0x7ffff7588ff0 <gdk_threads_dispatch>, user_data=0x635780) at ../glib/gmain.c:4800
#80 0x00007ffff6f7476f in g_main_dispatch (context=0x496df0) at ../glib/gmain.c:3309
#81 g_main_context_dispatch (context=0x496df0) at ../glib/gmain.c:3974
#82 0x00007ffff6f74af8 in g_main_context_iterate (context=0x496df0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4047
#83 0x00007ffff6f74e0b in g_main_loop_run (loop=0xb097e0) at ../glib/gmain.c:4241
#84 0x00007ffff781ba77 in gtk_dialog_run (dialog=0xbae9c0 [GtkMessageDialog]) at gtkdialog.c:1398
#85 0x00007ffff7f7eaea in run_ask_yes_no_save_generic_result_dialog (flags=ASK_YES_NO__YESFOREVER, key=0x6cee16 "abrt_analyze_smart_ask_perform_local_analysis", message=0x6cee44 "Do you want to generate a stack trace locally? (It may download a huge amount of data but reporting can't continue without stack trace).", parent=0x75e2c0 [GtkApplicationWindow]) at ask_dialogs.c:110
#86 0x00007ffff7f7ec30 in libreport_run_ask_yes_no_yesforever_dialog (key=0x6cee16 "abrt_analyze_smart_ask_perform_local_analysis", message=0x6cee44 "Do you want to generate a stack trace locally? (It may download a huge amount of data but reporting can't continue without stack trace).", parent=0x75e2c0 [GtkApplicationWindow]) at ask_dialogs.c:140
#87 0x000000000040b9d0 in run_event_gtk_ask_yes_no_yesforever (key=0x6cee16 "abrt_analyze_smart_ask_perform_local_analysis", msg=0x6cee44 "Do you want to generate a stack trace locally? (It may download a huge amount of data but reporting can't continue without stack trace).", args=0x897170) at wizard.c:1517
#88 0x00007ffff7fa82c7 in consume_event_command_output (state=0x9e7540, dump_dir_name=0x5c0800 "/var/spool/abrt/ccpp-2020-03-20-16:36:07.957321-1444190") at run_event.c:609
#89 0x000000000040bcaf in consume_cmd_output (source=0xb59c00, condition=G_IO_IN, data=0x897170) at wizard.c:1587
#90 0x00007ffff6f7476f in g_main_dispatch (context=0x496df0) at ../glib/gmain.c:3309
#91 g_main_context_dispatch (context=0x496df0) at ../glib/gmain.c:3974
#92 0x00007ffff6f74af8 in g_main_context_iterate (context=context@entry=0x496df0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4047
#93 0x00007ffff6f74bc3 in g_main_context_iteration (context=context@entry=0x496df0, may_block=may_block@entry=1) at ../glib/gmain.c:4108
#94 0x00007ffff718c86d in g_application_run (application=0x72a0f0 [GtkApplication], argc=<optimized out>, argv=<optimized out>) at ../gio/gapplication.c:2559
#95 0x00000000004117fb in main (argc=2, argv=0x7fffffffd910) at main.c:221

Comment 11 ekulik 2020-03-20 16:29:55 UTC
Seems that the crashing disappears with wrapping enabled on the text view. It’s something I wanted to already, but cannot recall why it didn’t happen.

Comment 12 ekulik 2020-03-20 17:08:44 UTC
I’ve proposed https://github.com/abrt/libreport/pull/607 for this.

Comment 13 Fedora Update System 2020-03-21 01:44:04 UTC
libreport-2.12.0-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-af976581e2

Comment 14 Geoffrey Marr 2020-03-23 19:38:11 UTC
Discussed during the 2020-03-23 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as as a conditional violation of the app "basic functionality" criterion, when abrt gui runs on X11, since it is part of default KDE install and KDE uses X11 by default, and even some GNOME installs fall back on X11.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-23/f32-blocker-review.2020-03-23-16.00.txt

Comment 15 Kamil Páral 2020-03-24 13:53:13 UTC
(In reply to Fedora Update System from comment #13)
> libreport-2.12.0-3.fc32 has been pushed to the Fedora 32 testing repository.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-af976581e2

This fixes the problem, thanks.

Comment 16 Fedora Update System 2020-03-25 01:56:19 UTC
FEDORA-2020-af976581e2 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 `{third: "Beedell", first: "Roke"}`{.JSON5} 2022-01-26 15:59:41 UTC
This is occurring for me during utilisation of Wayland and Rawhide.


Note You need to log in before you can comment on or make changes to this bug.