Bug 1815585 - [OSP16.1] Tempest run leaves orphaned snapshots
Summary: [OSP16.1] Tempest run leaves orphaned snapshots
Keywords:
Status: CLOSED DUPLICATE of bug 1815575
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 16.1 (Train on RHEL 8.2)
Assignee: Lukas Piwowarski
QA Contact: Martin Kopec
URL:
Whiteboard:
Depends On: 1843927
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-20 16:09 UTC by Martin Kopec
Modified: 2020-07-08 12:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-08 12:58:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1866988 0 None None None 2020-03-20 16:12:05 UTC
OpenStack gerrit 712356 0 None MERGED Cleanup images properly 2020-07-08 12:32:59 UTC

Description Martin Kopec 2020-03-20 16:09:07 UTC
This bug was initially created as a copy of Bug #1815575

I am copying this bug because: 



This bug was initially created as a copy of Bug #1768441

I am copying this bug because: 



Description of problem:


Version-Release number of selected component (if applicable):
openstack 3.14.3 

How reproducible:
Every full run of tempest overcloud verification leaves nova-objects

Steps to Reproduce:
1. Perform full tempest run
2. Cleanup is performed after the run
3. There are instances snapshots left after the cleanup

Actual results:
Following objects were left uncleaned after the tempest run, causing red popup errors in Horizon: "Unable to retrieve project".
Problematic objects:
tempest-ServersNegativeTestJSON-server-1006268429-shelved
tempest-TestShelveInstance-server-1930908003-shelved
Both are instance snapshots, type: RAW, visibility: Image from Other Project - Non-Public, with deleted parent project.

Expected results:
Cleanup leaves no orphaned objects

Additional info:
N/A

Comment 3 Martin Kopec 2020-07-08 12:58:52 UTC

*** This bug has been marked as a duplicate of bug 1815575 ***


Note You need to log in before you can comment on or make changes to this bug.