Bug 1815634 - [release-4.3] etcd: raft can stop before purge loop exists resulting in wal: file not found
Summary: [release-4.3] etcd: raft can stop before purge loop exists resulting in wal: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.3.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
: 1815646 1859558 (view as bug list)
Depends On: 1801196 1801237
Blocks: 1801379
TreeView+ depends on / blocked
 
Reported: 2020-03-20 19:04 UTC by Sam Batschelet
Modified: 2020-08-05 10:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1801237
Environment:
Last Closed: 2020-08-05 10:54:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift etcd pull 53 None closed Bug 1815634: bump etcd v3.3.22 2020-09-13 14:43:55 UTC
Red Hat Product Errata RHBA-2020:3180 None None None 2020-08-05 10:54:34 UTC

Comment 2 Dan Mace 2020-06-18 18:43:05 UTC
Fixed upstream in v3.3.18 (commit 069bce1).

Comment 4 Dan Mace 2020-07-14 14:15:50 UTC
*** Bug 1815646 has been marked as a duplicate of this bug. ***

Comment 8 ge liu 2020-07-20 04:39:51 UTC
No regression issue.

Comment 9 Sam Batschelet 2020-07-22 13:51:54 UTC
*** Bug 1859558 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2020-08-05 10:54:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.3.31 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3180


Note You need to log in before you can comment on or make changes to this bug.