Bug 1815684 - font installation fails with FcCacheFini assertion (using fontconfig 2.13.92-7)
Summary: font installation fails with FcCacheFini assertion (using fontconfig 2.13.92-7)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-20 21:55 UTC by Kalev Lember
Modified: 2020-03-24 17:50 UTC (History)
12 users (show)

Fixed In Version: fontconfig-2.13.92-8.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 17:50:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Kalev Lember 2020-03-20 21:55:56 UTC
I'm running into the following scriptlet failure when installing font packages in a container:

2020-03-20 21:48:58,014 - atomic_reactor.util - DEBUG - Running scriptlet: google-crosextra-carlito-fonts-1.103-0.12.201309   532/532
2020-03-20 21:48:59,727 - atomic_reactor.util - DEBUG - /usr/share/fonts: failed to write cache
2020-03-20 21:48:59,727 - atomic_reactor.util - DEBUG - fc-cache-64: fccache.c:795: FcCacheFini: Assertion `fcCacheChains[i] == NULL' failed.
2020-03-20 21:48:59,727 - atomic_reactor.util - DEBUG - /usr/bin/fc-cache: line 4:   351 Aborted                 (core dumped) /usr/bin/fc-cache-64 "$@"

This is with fontconfig-2.13.92-7.fc32.x86_64 that is already supposed to have a FcCacheFini assertion fix.

Full container build log: https://kojipkgs.fedoraproject.org//work/tasks/2972/42642972/x86_64.log

Comment 1 Akira TAGOH 2020-03-21 05:22:22 UTC
Thanks for reporting. hmm, is it reproducible? if yes, can you see which cache file was updated after that run? and then please attach the cache file *before* updating because that should triggers this. I can try to investigate it.

Comment 2 Akira TAGOH 2020-03-21 06:40:22 UTC
Nevermind. I got an reproducible way from Parag.

Comment 3 Kalev Lember 2020-03-21 09:41:32 UTC
Great, thanks! All I know how to reproduce it is to do 'fedpkg clone modules/flatpak-runtime;git checkout f32;fedpkg flatpak-build' which doesn't exactly help you, I think.

Comment 4 Fedora Update System 2020-03-23 05:49:02 UTC
FEDORA-2020-b67090b021 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b67090b021

Comment 5 Fedora Update System 2020-03-24 01:51:43 UTC
FEDORA-2020-b67090b021 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b67090b021`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b67090b021

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Kalev Lember 2020-03-24 08:42:23 UTC
Thanks! I can confirm this fixes the assertion for me.

Comment 7 Fedora Update System 2020-03-24 17:50:36 UTC
FEDORA-2020-b67090b021 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.