Bug 181570 - UI for password syntax enhancements needs to be created
UI for password syntax enhancements needs to be created
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
1.0.2
:
Depends On:
Blocks: 183369
  Show dependency treegraph
 
Reported: 2006-02-14 17:32 EST by Nathan Kinder
Modified: 2015-12-07 11:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:51:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (24.20 KB, patch)
2006-02-14 17:35 EST, Nathan Kinder
no flags Details | Diff
Screenshot of new UI (80.27 KB, image/png)
2006-02-14 17:39 EST, Nathan Kinder
no flags Details
Revised Diffs (30.25 KB, patch)
2006-02-15 12:49 EST, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nathan Kinder 2006-02-14 17:32:58 EST
We need to create Console UI for the new password syntax enhancements that were
recently added (bug 178867).
Comment 1 Nathan Kinder 2006-02-14 17:35:04 EST
Created attachment 124650 [details]
CVS Diffs
Comment 2 Nathan Kinder 2006-02-14 17:39:34 EST
Created attachment 124653 [details]
Screenshot of new UI
Comment 3 Nathan Kinder 2006-02-15 12:49:05 EST
Created attachment 124698 [details]
Revised Diffs

This revised set of diffs fixes an issue where the default values when setting
up a per-user or per-subtree password policy were all showing up as 0.	This
was due to DSEntrySet overwriting the default component values with a null
string if the passwordPolicy LDAP entry did not exist.
Comment 4 Nathan Kinder 2006-02-15 17:57:18 EST
Checked into directoryconsole (HEAD).  Reviewed by Rich and Noriko.

Checking in dirserv.properties;
/cvs/dirsec/directoryconsole/src/com/netscape/admin/dirserv/dirserv.properties,v
 <--  dirserv.properties
new revision: 1.3; previous revision: 1.2
done
Checking in panel/DSEntrySet.java;
/cvs/dirsec/directoryconsole/src/com/netscape/admin/dirserv/panel/DSEntrySet.java,v
 <--  DSEntrySet.java
new revision: 1.2; previous revision: 1.1
done
Checking in panel/PasswordPolicyPanel.java;
/cvs/dirsec/directoryconsole/src/com/netscape/admin/dirserv/panel/PasswordPolicyPanel.java,v
 <--  PasswordPolicyPanel.java
new revision: 1.2; previous revision: 1.1
done
Comment 5 Amita Sharma 2011-06-23 07:11:55 EDT
VERIFIED the DS Console for pwd policy.

Note You need to log in before you can comment on or make changes to this bug.