Bug 1815769 - please move /usr/libexec/vte-urlencode-cwd to vte-profile
Summary: please move /usr/libexec/vte-urlencode-cwd to vte-profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vte291
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1814181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-21 15:23 UTC by Jens Petersen
Modified: 2020-03-30 00:16 UTC (History)
3 users (show)

Fixed In Version: vte291-0.60.0-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-30 00:16:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Jens Petersen 2020-03-21 15:23:49 UTC
Description of problem:
See https://github.com/containers/toolbox/issues/390

Funnily enough I was waivering between filing this for toolbox in github or
bugzilla and then it turns out to be a vte291 bug...

vte291 in F32 introduces /usr/libexec/vte-urlencode-cwd which is used
by /etc/profile.d/vte.sh - hence the helper program should live in
vte-profile not vte291.

Version-Release number of selected component (if applicable):
vte-profile-0.60.0-1.fc32

How reproducible:
100%

Steps to Reproduce:
1. toolbox enter

Actual results:
1. bash: /usr/libexec/vte-urlencode-cwd: No such file or directory

Expected results:
No error

Additional info:
A workaround currently is to install vte291 in toolbox but it makes no sense
to have libvte installed in toolbox by default.

Comment 1 Kalev Lember 2020-03-21 17:26:24 UTC
Thanks, I've moved it to vte-profile in vte291-0.60.0-2.fc32

Comment 2 Fedora Update System 2020-03-21 17:37:14 UTC
FEDORA-2020-d984f61022 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d984f61022

Comment 3 Fedora Update System 2020-03-22 01:41:32 UTC
vte291-0.60.0-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d984f61022

Comment 4 Junjie Yuan 2020-03-23 07:52:19 UTC
*** Bug 1814181 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2020-03-30 00:16:21 UTC
FEDORA-2020-d984f61022 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.